USB ports not working

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

sajjadbaqir

Thread Starter
Joined
Aug 12, 2005
Messages
218
I have tried many different usb sticks and external hard drives that just dont seem to work with my computer. once i connect the device it loads up fine. the problem begins when i transfer data from my cpu to the usb storage. the transfer stops and i usually get an error balloon pop up in the bottom right corner saying that my usb device has malfunctioned and the connect usb device from my computer dissappears. my devices are fine since they work fine on my other computers and transfer files with no problem. So im assuming the problem is the usb ports of this computer. I have tried to uninstall and reinstall the drivers of usb ports from device manager but didnt help. any suggestions? oh and i have a Acer Aspire x1700.
 
Joined
Jan 16, 2011
Messages
119
The next things I'd try are:

1. "Disable" then "Enable" the USB Devices in Device Manager (different than uninstall and install)

2. Clean out all the ports with canned air

3. Open PC (I assume no responsibility if you damage your system or void your warranty) case and check that all associated wires and plugs are secure (I'd disconnect the connectors and blast them out with air, too).

4. While the PC is open, check to see if all of your usb ports are on the same card/slot (if they are, and none are working, then I'd suspect hardware; if you have ports on different cards that aren't working, I'd lean more toward software/driver issues).

I hope this helps a little! Good luck!
 
Joined
Feb 13, 2010
Messages
183
Try the suggestion above^^^

Restarting the computer has a 10% chance of solving problem also.
 

sajjadbaqir

Thread Starter
Joined
Aug 12, 2005
Messages
218
yes restarting does work. I can see the device again in my computer but again if i transfer any files the device crashes.
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Members online

Top