1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

USB ports stopped detecting devices... except mouse

Discussion in 'Windows 7' started by duders, Dec 23, 2009.

Thread Status:
Not open for further replies.
Advertisement
  1. duders

    duders Thread Starter

    Joined:
    Dec 23, 2009
    Messages:
    1
    OK!

    I'm running windows 7...
    I have 4 usb ports on the back, two on the front
    All usb ports appear to be giving power, i can charge things (except ipod), but no devices get recognized in windows


    So yesterday i plugged my camera into my computer and it cause my mouse to turn off. After which i plug my mouse into a different usb slot which seem to work. After a while i notice though that my mouse would lag and cause my computer to not response for a few seconds every once in a while... The next day when i came to my pc i notice my keyboard was turned off... I tried to move it to different ports and in every port i would get "Device not Recognized or malfunctioning..." No usb device gets recognized anymore, except my razor mouse, for some reason this gets identified.

    Right now i have no keyboard and i can't go into my bios or re-install my OS... I tried putting BOTH my keyboard and mouse into usb-ps/2 converters but when i plug them into the ps2 ports nothing happens... no windows device sounds, nothing happens...

    I tried uninstalling my usb controllers from device manager, as well as manual install my dell keyboard drivers (NEITHER DID ANYTHING)

    I'm pretty much lost for ideas here...
     
  2. TerryNet

    TerryNet Moderator

    Joined:
    Mar 23, 2005
    Messages:
    78,246
    First Name:
    Terry
    PS/2 ports are, I think, not plug and play. Try shutting down the system and then boot with the keyboard/mouse plugged into the PS/2.
     
  3. mrcrassic

    mrcrassic

    Joined:
    Dec 23, 2009
    Messages:
    21
    Is this a desktop or laptop? Are the ports on the computer itself, or is this a hub? Sounds like a power issue. Are you having any other weird problems that are not related to USB ports malfunctioning?

    At this point, I'd say that your USB controller is shot, since all of the ports are picking up your stuff, but can't actually use them. Before this happened, did you notice that speeds dropped to 1.1 speeds?
     
  4. Rollin' Rog

    Rollin' Rog

    Joined:
    Dec 9, 2000
    Messages:
    45,855
    Since you have reinstalled the Controllers, try uninstalling the "code 45" devices which can only be seen with the following directions >>

    I am linking a registry patch you will need to download, unzip and run. Confirm the merge to the registry.

    http://forums.techguy.org/attachments/100544d1173412107/usbghosts.zip

    Once you have installed the patch, open the Device Manager and select View > Hidden Devices.

    Now open the USB Controller Device tree and look for "ghosted" or grey entries that show a "code 45" status when you double click them to view their properties.

    Uninstall all those devices and reboot; you may need to reboot twice.

    Then try your problem USB device again and see if it is detected properly.
    ----------------------------------------------------------

    The above is a long-shot as I also agree that this is probably a motherboard hardware problem with the ports not getting adequate power.
     
As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/887784

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice