USB printer/backup hd missing

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

hermit

Thread Starter
Joined
Sep 9, 2002
Messages
53
On a Vista 32x os, running a gateway GM5626, I have a USB printer and USB harddrive that went missing, (according to Vista), since approximately 3/23/10, (my last succesful back up).

The printer is a HP PSC 1410V ALL-IN-ONE.
The drive is a Western Digital 2500, (set up as a slave through a Dynex usb).

They were working fine for over a year, and all of the sudden they aren't detected.

The computer notices when I turn the drive on/off however, I get the "rim-shot/ du-dump" sound from vista when I connect it/ power it on. But when I look in the "my computer" file, it isn't there.

I am using "driver detective 6.5.0.5" and followed all of there reccomendations. Also I have gone to Windows update/ HP's website and downloaded everything they had. But the HP digital monitor does not detect any HP devices.
 

hermit

Thread Starter
Joined
Sep 9, 2002
Messages
53
Yes, I have an xbox 360 wireless reciever, and a usb mouse that are working fine.
 
Joined
Feb 17, 2008
Messages
2,637
hiya,could you try this,connect printer and external drive then reboot.when back to full desktop loaded right-click My computer>manage>disc management,can you see your devices in there,if in there right -click on one and select activate
 
Joined
Feb 17, 2008
Messages
2,637
try uninstalling all usb controllers,reboot and let your machine reinstall them automatically,unplug all usb devices from your machine,except your mouse,see if any help
 

hermit

Thread Starter
Joined
Sep 9, 2002
Messages
53
Sorry it has taken me so long to reply, and thanks for your help.

On Vista, how do you uninstall the usb controllers?
 
Joined
Feb 17, 2008
Messages
2,637
Hermit hiya,go into device manager right-click on one and select uninstall,once you have uninstalled all reboot and the pc will install them automatically
 

hermit

Thread Starter
Joined
Sep 9, 2002
Messages
53
Ok my printer is working! KUDOS! The HP printer monitor says that it is disconnected but it is printing so horray!

The computer is still not detecting the external drive, and now I don't get the "bu-bump" sound when I disconnect the usb cord or cycle the power to the drive. I looked at the Dynex site and couldn't find a driver that supports Vista.
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Staff online

Top