Using a Maxtor 60GB drive as an External

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

a0sz3

Thread Starter
Joined
May 3, 2002
Messages
3
I am trying to use a Maxtor Hard drive as an external drive.

The problem is that the drive is not being recognized. The drive just spins, stops, spins, stops, etc. I have inserted the drive into my computer as a slave drive and it reads and writes fine.

I have made sure that the drive is set as Master when I try to hook it up with through USB in the external case.

I have also tried another drive in the external case and it reads and writes just fine.

Any ideas why my maxtor drive is not working with the external case?

Thanks
 
Joined
Nov 7, 2002
Messages
1,278
Some drives take more amperage than others the PSU in the external casing is very limited, some models are designed for specific hard drives and if a drive is installed that exceeds a certain current draw it does not function properly. It is also possible that you have an old casing that does not have a new enough bios to support the drive.

Good Luck
 

a0sz3

Thread Starter
Joined
May 3, 2002
Messages
3
Thanks for the suggestions.

Since I don't want to go and purchase a new case I have just decided to use my older 20GB HD instead of the newer 60GB.
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Staff online

Top