Very poor audio with HyperX Cloud Alpha S

Capirossi

Thread Starter
Joined
Jul 10, 2020
Messages
1
Hi all,

I finally managed to break my old set of Cloud II's... I've been very happy with them though so earlier today I decided to pick up the Cloud Alpha S as a replacement. Immediately after plugging them in I noticed that the audio was very quiet and static-y, and that when I enabled the 7.1 surround sound it was like listening to everything through a cardboard tube with wind rushing by my ears... obviously not working as intended.

I contacted customer support and was given an email with a link to the HyperX firmware updater and instructions to get it working. Unfortunately that only partially fixed the issue. It got the audio working fine in web browsers and in discord, but other applications (overwatch, osu are all I've tested so far) have the same quiet/low quality audio. I also double checked that the correct audio driver (Cloud Alpha S Game) was enabled as the output device in both of those applications.

I've been looking up possible causes/talking to more technologically inclined friends all day and got:
- Defective product (I think the USB dongle is called a DAC? It would be that because audio sounds better when I plug the 3.5mm jack into my phone, doesn't sound great though because of the high impedance)
- The soundcard on the motherboard can't handle the higher impedance (my understanding is that would only be an issue if I was using the jack and it shouldn't affect USB audio)(motherboard specs pasted at bottom)
- Some sort of audio driver or software issue (I have disabled all non-hyperx drivers and they are definitely up to date. Windows spatial sound is off so it shouldn't be interfering with the HyperX surround sound. I've tried lots of different settings/reset everything to default/even updated windows but no dice)

Unfortunately this pc is my only windows device so I can't really test the dongle any of my Macs/chromebooks, and as I said before it seems to work fine with just the jack plugged into my phone.

I could just use the headset without the dongle, but the cord is inadequately short and I want to have the functionality of the DAC. Also, at some point about a year ago I screwed up the audio drivers somehow and never really tried to fix it. The front 3.5mm jack no longer works, and the one directly connected to the motherboard functions but has the same issue as the Cloud Alpha's do with quiet, low quality audio. That's probably fixable if I tried, but again that's not really the solution I'm looking for as I'd really like to get the DAC working properly if possible.

As a temporary fix I've checked the loudness equalization box for the HyperX output device. I at least gets my games running to the point where I can hear them well, but it still sounds much worse than it should.

Unfortunately there is no actual HyperX software that I can interact with on this pc to try to fix the issue. All I have access to is the updater, the buttons on the DAC, and the beta software "NGENUITY" which is pretty limited (and I've already exhausted all the settings on there with no fix to my issue and I have since uninstalled).

I would greatly appreciate any advice or insight for this issue. I've been looking all over the internet and have found some people with similar issues but no solutions. The tech support guy did not respond to my email where I told him that his solution did not fix the issue. I've posted on the techsupport and hyperx subreddits with no responses yet. I just found this website about an hour ago and did a little searching but didn't see anything related to my issue. Hopefully I followed the rules and formatted properly with this post, but please let me know if I did anything incorrectly.

Thank you!

Tech Support Guy System Info Utility version 1.0.0.9
OS Version: Microsoft Windows 10 Home, 64 bit, Build 18362, Installed 20190818102346.000000-420
Processor: AMD Ryzen 5 1600 Six-Core Processor, AMD64 Family 23 Model 1 Stepping 1, CPU Count: 12
Total Physical RAM: 16 GB
Graphics Card: NVIDIA GeForce GTX 1060 6GB
Hard Drives: C: 232 GB (32 GB Free); D: 931 GB (188 GB Free); E: 931 GB (445 GB Free);
Motherboard: ASUSTeK COMPUTER INC. ROG STRIX B350-F GAMING, ver Rev X.0x, s/n 180322955100376
System: American Megatrends Inc., ver ALASKA - 1072009, s/n System Serial Number
Antivirus: Windows Defender, Enabled and Updated
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Staff online

Top