Video Card drivers for 6800 Ultra, please?

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

bobcoolos

Thread Starter
Joined
Feb 4, 2005
Messages
316
Does any one know the best up to date Video Card drivers for a G-Force 6800 Ultra. B/c i recently up dated my drivers for my video card and i now get a rilly bad video destortion. Any videos/clips i watch in my media player now look rilly bright like roll of film that has been exposed to sunlight.

If any one can find me the best drivers for my video cards thanks in advance.


Thanks,
~Da Bob~
 
Joined
Sep 1, 2004
Messages
1,756
Go into the Nvidia display properties and reduce the gamma correction level.
 

bobcoolos

Thread Starter
Joined
Feb 4, 2005
Messages
316
Arcadion said:
Go into the Nvidia display properties and reduce the gamma correction level.
Nope, not working, all it does is make everything else look discolored and distorted and has no affect on the media being played. This problem is the same for all media players. Everything else if fine, just movie/video playback is messed up since the new driver up date.
 

bobcoolos

Thread Starter
Joined
Feb 4, 2005
Messages
316
I removed overlays, what ever they are in my windows media player and it fixed the color distortion problem. But all my other players still have the problem. They all worked fine before the new driver. Games kept tell me to update so i did, fixed a few problems in games but created this problem.
 
Joined
Aug 1, 2003
Messages
51,988
Try the next newer driver. Maybe the earlier one will work better. Also try installing the driver in Safe Mode.
 
Joined
Jul 19, 2005
Messages
467
Hi I'm new here. Now I can understand updateing the newer drivers. (thats a no brainer) But did the picture(s) look fine with out the newer drivers? If yes, in that case why don't you go and to system restore and roll back before the drivers were installed. If the roll back wont do it just right click on "My computer" select "propertys" "click on "hardware" then click on "device manager" find your video card, right click and select "propertys" then click on "uninstall drivers". It might ask you to restart your computer, I would do it.

I hope that helped,

bigk
 

bobcoolos

Thread Starter
Joined
Feb 4, 2005
Messages
316
Elvandil said:
Try the next newer driver. Maybe the earlier one will work better. Also try installing the driver in Safe Mode.
I dont know how to get an exact ver of a driver i just went to the nvidia web site the the link from my game kept giving me and i downloaded a file that works for all cards. Not one is spific, like for 6800 cards only. So if any one can find me a link the 6800 ultra card drivers only that would rilly help. I would just roll back to my old driver but it fixed some shading errors in my games.
 
Joined
Jul 19, 2005
Messages
467
Your current one is 19 megs? but Elvandil provided you with a 20 meg driver(s)? mmm.... interesting. Are you totaly postive you have the newest drivers? Try going into DirectX and is what version you have and comepare it to the 20 meg driver(s). Or you can just right click on the desk top and select "propertys" and go to your graphics card panel and and try to find a info buttion. Why dont you download the 20 meg version. Create a restore point, then install the drivers. Its worth a shot. If some thing goes wrong, go into safe mode and restore from your saved piont.

I'm not sure if he talking about the smae safe mode as I'm about to mention. But I'll give it a shot.

1.) Turn off your computer.
2.) Wait 10 seconds, wait for every thing to shut down.
3.) Turn your computer back on.
4.) When it beeps, hit F8.
5.) Choose safe mode.
6.) You'll enter windows in safe mode. It may little alittle different then what you usually see in windows.
7.) Choose your restore piont. Travel back in time. (lol) That sounded funnie. :)
8.) Now your computer should restart, but it should restart in normal mode.
NOTE: If it does not restart in normal mode, no shut down the computer, turn it back on, listen for beep, hit F8, choose "start windows in normal mode".


bigk :)
 

bobcoolos

Thread Starter
Joined
Feb 4, 2005
Messages
316
I fixed it in my Windows Media Player, and i think it plays normal now. But somthing with the new driver did somthing to the overlays options, what ever it does. I just went under performance in WIndowas Media Player and un-checked "use overlays"

I checked the driver ver, it is ver 77.72. I mostly only use Windows Media Player so i guess i can live with the problem in the other media plays for now or i find some other worse problem.
 
Joined
Aug 1, 2003
Messages
51,988
If you tap F8 just as your machine boots up. you will get some boot options, including Safe Mode. Have the driver on the desktop and ready to install once you get into Safe Mode. Install it and reboot normally.

If your downloaded driver is a different size and the same version, it may be a corrupt download. It would be a good idea to try it again.
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Staff online

Top