Video corruption in Crysis demo

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Bundo413

Thread Starter
Joined
Nov 3, 2007
Messages
21
I was wondering if anyone else was having this problem. The demo installs fine and the menu looks okay, but once the game begins, there are dark textures, black flashes, or missing textures. It is especially noticeable during the initial parachute drop where, if you look right at the island, it disappears completely. My video drivers are up to date. If anyone can help, please do so.

-Bundo
_____________________________________
Windows XP
AMD Athlon 64 3000+ (~2.0Ghz)
VisionTek Radeon X1600 XT Extreme Gamer Edition 512 MB
On-Board Audio
1 GB Ram
 
Joined
Mar 22, 2007
Messages
913
I had/have this too ... I have an nvidia card and I know they released beta drivers for crysis (I'll wait till the proper one's come out) and maybe ATI have done the same.

If not I'm sure they will release new drivers when the game come out in full.:)
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Members online

Top