Video is not playing well since I have downgraded.

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

pratim96

Thread Starter
Joined
Oct 8, 2019
Messages
2
Few days back I downgraded from Windows 10 to Window 8 (64 bit). Since then video is not playing well offline as well as online. Video plays but it is shaky at times. Please help.
 
Joined
Sep 21, 2007
Messages
14,335
Go to Control Panel > Device Manager > Display Adapter . Right click on driver and choose Update
 
Joined
Sep 21, 2007
Messages
14,335
Go to the GPU's site and see if they have a driver for Win 8. Maybe that one could be better.
 

Oddba11

Jim
Joined
May 12, 2011
Messages
8,361
Did you MANUALLY install all of the hardware drivers (ie: motherboard, audio , video, etc.) or are you relying on Windows?

Windows typically only installs their latest certified driver(s), and those are only basic drivers meant to ensure the hardware is functional. Typically, the manufacturers drivers are required for best performance and to ensure all features are operational.
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Members online

Top