Videos are laggy and stutter

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Jsten

Thread Starter
Joined
Jul 17, 2018
Messages
1
For some reason I can't get videos to play on my new computer.

I've played the same video a number of players including VLC, Films & TV, Windows Media Player, 5KPlayer, PowerDVD and I have even uploaded videos to YouTube for testing and opened it up in a video editor called HitFilm Express.

I have downloaded the K-lite codec pack and the CCCP codec pack which did nothing.

I have messed around with a number of settings in VLC player with no luck.

The they lag and stutter in different places every time and lag differently on some of the players so it's not the video file.

It lags in HitFilm Express.

It plays almost flawlessly in 5KPlayer and super close the flawlessly in PowerDVD.

But the strangest part is that it plays 100% flawlessly once I upload it to YouTube.

Plays fine on my Macbook Air.

Can anyone think of what the problem could possibly be?

Specs
i7 8700
16 GB RAM
1080 Ti OC
Windows 10 home 64-bit
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Staff online

Top