Vista and HP Deskjet F380

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

invicta1

Thread Starter
Joined
Mar 26, 2008
Messages
1
I installed Vista on my PC this weekend and my HP Deskjet F380 has disappeared!

My PC knows when the printer is plugged into the UCB port and when its removed. When I turn it on a window tells me it found new hardware. Eventually I tell it to search the internet - its says it found new hardware HP Deskjet F300 series.

I downloaded the drivers from HP's site. Installed. It recognized when I plugged the printer into the port while I was installing the software - at its request. At the end of the installation the window disappeared (it took something like two hours to handle the hardware part) and it doesnt recognize the hardware is a printer. Let alone an HP printer. Then the same old window appears telling me it found new hardware, etc

I deinstalled all of it and redid it. Same result.

So what to do? I saw some other problems with HP printers and Vista but not my printer in particular and not exactly my problem.
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Staff online

Members online

Top