1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Vista partition broken by linux installation

Discussion in 'Windows Vista' started by onda_trollet, Jul 24, 2008.

Thread Status:
Not open for further replies.
Advertisement
  1. onda_trollet

    onda_trollet Thread Starter

    Joined:
    Jul 24, 2008
    Messages:
    2
    Short story: I installed Debian yesterday, latest version on my laptop. I had previously tried Slackware 12.1 which worked perfectly, but I never got internet to work. I have installed same Debian 2 months ago without any problems. I also have Vista (premium?) factory installed on the same hardrive as dualboot.

    So... Debian yesterday. Grub bootloader. I always use lilo for slack though. I can see vista in the menu options. choose it... computer thinks and ponders a while and i see the normal "microsoft... something..." before i can log on to vista. but i cant log on. instead i get some acer rescue menu. it cant find the reason for me not being able to start vista. and there is no rescue point available according to it.

    so... i try to install slack, hoping lilo will fix it [​IMG] hehe. i am not good with linux, you know. anyway... lilo works and everything... but i still cant log on to vista.

    after trying to mount my win partition through linux to see if all is wasted or if the files are still there... it says it cant be mounted, check syslog. i am not good with reading syslog, but i see this:

    invalid boot secot checksum

    so fdisk -l in linux showed this:
    fdisk -l:
    Device Boot Start End Blocks Id System
    /dev/sda1 * 1 1275 10240000 27 Unknown
    /dev/sda2 1275 8570 58597087+ 83 Linux
    /dev/sda3 8570 8813 1951897+ 5 Extended
    /dev/sda5 8570 8813 1951866 82 Linux swap

    My vista partition is "unknown".

    i tinker some more in linux and manage to mount sda1 and ls it. I find files, but not "my files". they seem to be some sort of default files for that partition. I use the dos prompt in the acer rescue menu and find the same files.

    looks like a big problem! is there anyway for me to fix this so i can log on to vista again? really depressed because i have a lot of important stuff on my win partition (and about 50 hours playtime on oblivion :) ). i can live with having to reinstall the whole computer and loose oblivion save, as long as i can save my photos and all those things.

    thankful for help...
     
  2. JohnUSAF

    JohnUSAF

    Joined:
    Sep 16, 2005
    Messages:
    61
    I would try to mount your windows partition using windows recovery console. Do you still have access to your Vista disk? If so I would boot using that and use recovery console to fix the MBR. I had this problem once when I deleted a linux partition on a dual boot XP/Fedora laptop. All I did was do recovery console and for the life of me I cannot remember the command but it worked. It's something like fixboot or fixmbr.
     
  3. Mumbodog

    Mumbodog

    Joined:
    Oct 3, 2007
    Messages:
    7,891
  4. TechB

    TechB

    Joined:
    Jul 23, 2006
    Messages:
    446
    It sounds like grub is pointing to your Acer recovery partition instead of the Vista partition. Look in /boot/grub/menu.lst (in Linux) and see what partition grub is chaining to to load Vista. It's very likely that editing this file to point to the correct partition will allow you to boot to Vista.
     
  5. onda_trollet

    onda_trollet Thread Starter

    Joined:
    Jul 24, 2008
    Messages:
    2
    startup repair does not work. and vista was preinstallad when i got it, no dvd. i need to do alt+f12 at boot to do a clean slate install of vista. i will try those commands though and see if they do any good. i am beginning to think though that i accidently erased my vista partition and thats the reason why it wont boot. the 10gb unknown partition probably is the recovery partition for reinstalling vista. i think so because the emergency repair to install vista again is on a hidden partition according to the manual.

    thanks for the help though!
     
  6. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/733383