1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Vista Wireless DHCP Problem

Discussion in 'Windows Vista' started by Jock_McTartan, Oct 30, 2007.

Thread Status:
Not open for further replies.
  1. Jock_McTartan

    Jock_McTartan Thread Starter

    Joined:
    Sep 19, 2007
    Messages:
    9
    Hi all

    Got another Vista wireless networking problem.

    Running Vista Business and connecting to a 3Com Officeconnect wireless router - this is set as a DHCP server with a pool of 5 addresses - MAC address filtering and WEP are enabled.
    We also have another DHCP server on the same subnet (not a great idea I know but the boss's decision unfortunately)

    When I connect to the 3Com, although it connects successfully, it uses the other DHCP server to assign a valid IP but doesn't assign DNS settings. Both can assign these ok, tested with XP.

    I would have thought that this was the other DHCP answering before the router if it assigned the full details but it doesn't assign the DNS or gateway.
    I tried using the TIDs from MS to adjust the broadcast flag to see if it was an issue with the type of router but makes no difference. Have also tried other KB articles and changed the values for the DHCP in the registry (changes back to the incorrect one once connected)

    Things I've tried with no success:

    Recreate the connection
    Manually assigning an IP etc works ok
    Disabled MAC filtering and encryption - same results.
    Disabled IPv6
    Changed Broadcast flag
    Manually edited details in registry
    Release/renew/flush ipconfig
    Searched here and other places for solutions and tried most....

    One more bizarre thing that happened is that this same problem was affecting 2 laptops running Vista - one of them picked up valid info from the 3Com and has stuck with it - even after the lease would have expired.....can't explain what happened for it to connect (other DHCP didn't reply in time?)

    Code:
    +-------------+     +-------+     +----------+
    |Vista Laptop |---->|Router | --->|Other DHCP|
    +-------------+     +-------+     +----------+
    
    * Any ideas why the 3Com won't dish out IP/GW/DNS etc?
    * Why the replying DHCP only gives out IP?
    * How to fix it? ;)

    Any help appreciated :)
     
As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/645531

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice