1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Vista's Boot Loader Preventing XP From Installing

Discussion in 'Windows XP' started by grrrate, Oct 20, 2007.

Thread Status:
Not open for further replies.
Advertisement
  1. grrrate

    grrrate Thread Starter

    Joined:
    Oct 20, 2007
    Messages:
    3
    Hello,

    I decided to upgrade to Vista today from Windows Xp. Rather than doing the upgrade process, I decided to start off with a fresh format/install.
    Unfortunately, after the first reboot in the Vista setup process (where Vista attempts to load data from the HDD) the system would just sit there after post as if the Vista loader couldn't properly detect the partition.

    I currently don't have time to troubleshoot the Vista problem with my system, so in desperation I have tried to go back to XP.

    I am able to boot into Windows XP setup, format the drive, and copy over the beginning essential files. However, after the system reboots after the initial copy of the data... XP is not capable of booting from the hard drive. It just sits there and nothing happens.... this was not a problem before I tried to install Vista.

    To check if a problem had occurred with the drive, I installed Ubuntu Linux. Ubuntu is able to boot from the drive without any problems. However....... when Ubuntu loads grub, it detects the following on the MBR:

    Windows Vista/Longhorn Loader


    The Vista loader appears to be preventing Windows XP from properly booting from the hard drive. The drive is a Western Digital 320gb. I have 30 gbs set aside for Windows to boot from. The rest of the drive is another partition with files I cannot afford to lose....

    I hope someone can help me, this has been a frustrating afternoon.

    Thanks in advance for your time.
     
  2. peterh40

    peterh40

    Joined:
    Apr 15, 2007
    Messages:
    1,405
    First Name:
    Peter
    Looks like it has not properly removed all the Vista boot loader stuff esp from the MBR. Boot into recovery console and try the fixmbr or fixboot commands to rewrite mbr
    .
     
  3. grrrate

    grrrate Thread Starter

    Joined:
    Oct 20, 2007
    Messages:
    3
    Thanks for replying.

    I've used the recovery console and did fixmbr and fixboot, windows said it repaired the boot record. Unfortunately, after trying to install XP again after, I'm stuck in the same spot. The computer sits there without being able to boot from the harddrive. Any other advice would be greatly appreciated.
     
  4. grrrate

    grrrate Thread Starter

    Joined:
    Oct 20, 2007
    Messages:
    3
    I fixed the boot record using Super Grub livecd. However, it looks like all the data on my second partition has been lost :(. Looks like I need to find a way to recover it if it's even possible.
     
  5. The Hound

    The Hound

    Joined:
    May 27, 2007
    Messages:
    3,235
    Welcome to TSG...probably too late for this, but Microsoft has this to say about going back (some would say moving forward again) from Vista to XP...
     
  6. peterh40

    peterh40

    Joined:
    Apr 15, 2007
    Messages:
    1,405
    First Name:
    Peter
  7. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/641063

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice