1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

VLC player not displaying Cyrillic subtitles correctly

Discussion in 'Multimedia' started by em5750, May 31, 2012.

Thread Status:
Not open for further replies.
Advertisement
  1. em5750

    em5750 Thread Starter

    Joined:
    Oct 16, 2010
    Messages:
    4
    As the title states, VLC player displays Russian subtitles as question marks. I've changed the text encoding to Cyrillic (Windows-1251), UTF-8 autodetection and Formatted Subtitles both checked. The subs are .srt format.

    The video file is HD and is an MKV file, that's why I used VLC. Any ideas? I already tried downgrading to version 1.1.
     
  2. pip22

    pip22

    Joined:
    Nov 21, 2004
    Messages:
    2,536
    Try this:

    Navigate to Preferences --> Subtitles & OSD in VLC and choose the following values:

    Default encoding: GB18030
    Display Settings, Font Arial Unicode MS
     
  3. em5750

    em5750 Thread Starter

    Joined:
    Oct 16, 2010
    Messages:
    4
    Couldn't find this encoding. They all go by name. What's the name of GB18030?
     
  4. Oddba11

    Oddba11 Jim

    Joined:
    May 12, 2011
    Messages:
    4,642
As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/1055303