1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

W7 + device driver failed to install

Discussion in 'Windows 7' started by gibson68, Nov 12, 2012.

Thread Status:
Not open for further replies.
Advertisement
  1. gibson68

    gibson68 Thread Starter

    Joined:
    Nov 12, 2012
    Messages:
    7
    Operating System
    MS Windows 7 Home Premium 64-bit SP1
    CPU
    Intel Core i5 750 @ 2.67GHz 37 °C
    Lynnfield 45nm Technology
    RAM
    4.00 GB Dual-Channel DDR3 @ 668MHz (9-9-9-24)
    Motherboard
    MICRO-STAR INTERNATIONAL CO.,LTD P55-GD65 (MS-7583) (CPU 1) 35 °C
    Graphics
    SyncMaster ([email protected])
    ATI Radeon HD 4770 (XFX Pine Group) 51 °C
    Hard Drives
    932GB Western Digital WDC WD1001FALS-00J7B1 ATA Device (SATA) 37 °C
    Optical Drives
    HL-DT-ST DVDRAM GH22NS50 ATA Device
    Audio
    Realtek High Definition Audio
    Operating System
    MS Windows 7 Home Premium 64-bit SP1
    CPU
    Intel Core i5 750 @ 2.67GHz 37 °C
    Lynnfield 45nm Technology
    RAM
    4.00 GB Dual-Channel DDR3 @ 668MHz (9-9-9-24)
    Motherboard
    MICRO-STAR INTERNATIONAL CO.,LTD P55-GD65 (MS-7583) (CPU 1) 35 °C
    Graphics
    SyncMaster ([email protected])
    ATI Radeon HD 4770 (XFX Pine Group) 51 °C
    Hard Drives
    932GB Western Digital WDC WD1001FALS-00J7B1 ATA Device (SATA) 37 °C
    Optical Drives
    HL-DT-ST DVDRAM GH22NS50 ATA Device
    Audio
    Realtek High Definition Audio

    Have tried to resolve issue with Canon powershot S50 connected by USB no longer functioning with W7.
    On occasions the only response is the pop up message driver device failed to install.
    The camer is recognised under " Device and Printers" When I trouble shoot response is to visit manufacturers site and download driver - not required under Windows compatibility listing.
    Have gone to Device Manager and removed all reference to Canon Camera under Portable devices but get same result. Have had a Microsoft IT tech look at the computer but he is at a loss.

    Same problem has occured on another computer running W7 Home edition.
    Any help would be appreciated. Program worked when W7 first installed.
     
  2. dai

    dai

    Joined:
    Mar 6, 2003
    Messages:
    11,198
  3. gibson68

    gibson68 Thread Starter

    Joined:
    Nov 12, 2012
    Messages:
    7
    Thanks for your response dai. Have gone to site you recomend and get the following "There is no driver for the OS Version you selected. The driver may be included in your OS or you may not need a driver.

    I have downloaded software from same site but get same result when installed. System used to work fine.

    Could there be a conflict with other software such as HP Photosmart C5180 or Logitech webcam or PDF printer?
     
  4. huggie54

    huggie54

    Joined:
    Feb 17, 2008
    Messages:
    2,637
    hiya,boot into safe mode,when fully booted plug in your camera and turn on.try all USB ports.
     
  5. gibson68

    gibson68 Thread Starter

    Joined:
    Nov 12, 2012
    Messages:
    7
    Thanks Huggie54(n)

    tried your suggestion but unfortunately end up with same response 'device driver was not sucessfully installed'. Hopefully there is a solution. This problem has occurred on two of our computers whilst a third also W7 Home recognises the Powershot S50 camera and another Canon Powershot S515. Both cameras were previously recognised and downloads were no problem. We now have to download via card reader on HP C5180 printer:confused:
     
  6. huggie54

    huggie54

    Joined:
    Feb 17, 2008
    Messages:
    2,637
    did you install the printer or webcam after camera drivers,have you tried uninstalling them and then see if camera works
     
  7. gibson68

    gibson68 Thread Starter

    Joined:
    Nov 12, 2012
    Messages:
    7
    Hi Huggie 54

    Uninstalled drivers for HP C5180 and Logitech webcam. Went to Device Manager , view, show hidden devices and there were two refences to Canon camera under Portable Devices. Uninstalled then connected camera. Using new Canon Camera ref opted for update driver and Windows installed MTP USB Device. Reconected camera and still get 'device driver was not successfully installed'.

    In answer to your question the HP software keeps reinstalling itself so we have attemtped to resolve problem with and without possible conflicting software installed.
     
  8. dai

    dai

    Joined:
    Mar 6, 2003
    Messages:
    11,198
    try another cable to connect to the computer
     
  9. gibson68

    gibson68 Thread Starter

    Joined:
    Nov 12, 2012
    Messages:
    7
    Hi dai thanks for your continued input. don't think the usb cable is the problem. works fine on 2 other computers with W7 Home and W7 Pro. Have previously tried another cable but no luck.
     
  10. dai

    dai

    Joined:
    Mar 6, 2003
    Messages:
    11,198
    run

    sfc /scannow

    see if that picks up any changed system files

    then try it again
     
  11. gibson68

    gibson68 Thread Starter

    Joined:
    Nov 12, 2012
    Messages:
    7
    Hi dai - tried sfc/scannow - got response ...'windows cannot find 'sfc/scannow'. Makle sure you typer the name correctly and then try again
     
  12. dai

    dai

    Joined:
    Mar 6, 2003
    Messages:
    11,198
    copy and paste

    sfc /scannow

    it looks like you have missed the space after the c
     
  13. huggie54

    huggie54

    Joined:
    Feb 17, 2008
    Messages:
    2,637
    gibson68,when you uninstall the printer and webcam from device manager you have to remove their connecting cables or the drivers will reinstall for these devices.
     
  14. gibson68

    gibson68 Thread Starter

    Joined:
    Nov 12, 2012
    Messages:
    7
    Hi sfc /scannow - the copy and paste did not bring up a windows screen.Dia. Thanks again for your continued effort. Yes when I deleted the driver I removed the cables.
     
  15. dai

    dai

    Joined:
    Mar 6, 2003
    Messages:
    11,198
    try pasting it into the command promnt box
     
  16. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/1076522

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice