WD Firmware updater loses my External MYBook

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

shoogleguy

Thread Starter
Joined
Mar 17, 2006
Messages
143
I did a dumb thing, I guess. Ran this WD Firmware updater and my external drive 'MyBook' does not show up.
What can I do to get it back?
Thanks in advance.
KGJ
 

managed

Allan
Moderator
Joined
May 24, 2003
Messages
15,059
Do you have a link to the 'WD Firmware updater' you used ? What version of Windows is running ? Is this on the PC in your Computer specs running an AMD XP2000 Cpu ?
 

shoogleguy

Thread Starter
Joined
Mar 17, 2006
Messages
143
Sorry I should have given the info
Le Novo box
E6750 @ 2.6GHz
RAM 4.00G
32 bit
Windows Vista business

WDFirmware Updater used.
 

managed

Allan
Moderator
Joined
May 24, 2003
Messages
15,059
All I can thin k of is taking the drive out of the enclosure and if possible connecting it directly to a computer and hoping it shows up.
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Members online

Top