WD passport 120gb drive not recognised

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

pgrunion

Thread Starter
Joined
Nov 1, 2007
Messages
2
Hello
I have been using a wd passport usb drive for the past 6 months, no problem. I plugged it into my Dell desktop today and it seems to run, blue light comes on etc. However I cannot access the drive, even through my computer. It used to be my f:/, it is not listed anymore.

I tried the Diskmgmt.msc but the drive does not come up in the listing

Any help on this would be appreciated as I have 5 years of digital images stored on it

Thanks

Paul
 

pgrunion

Thread Starter
Joined
Nov 1, 2007
Messages
2
Yes, this it is connected to the same computer. In the past when I connected it, no problem, it was recognised and I could find F:\ in my computer!

Very frustrating
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Staff online

Members online

Top