1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

WD Passport external hard drive

Discussion in 'Hardware' started by Peter23, Sep 23, 2007.

Thread Status:
Not open for further replies.
Advertisement
  1. Peter23

    Peter23 Thread Starter

    Joined:
    Sep 22, 2007
    Messages:
    4
    hi i'm new here... is anyone familiar with external drives.?
    i'm having a problem with the WD 160 gb passport...
    it shows up on my laptop and i hear it running ... but
    it's not showing up on any of the drives...

    it usually would show up on drive F, but no more...

    can someone tell me how to fix it?

    thanks
     
  2. 07clarkm

    07clarkm Banned

    Joined:
    Jul 24, 2007
    Messages:
    624
    OK check all connections first.

    Power, USB the lot.
     
  3. JohnWill

    JohnWill Retired Moderator

    Joined:
    Oct 19, 2002
    Messages:
    106,418
    Start, run, diskmgmt.msc

    Do you see the drive there?
     
  4. Peter23

    Peter23 Thread Starter

    Joined:
    Sep 22, 2007
    Messages:
    4
    I checked connections on all usb ports.. the WD passport is powered I see the blue light...
    it just doesn't register in the drives..

    I did a Start Run of > diskmgmt.msc but no luck...

    what could i try next?

    thanks
     
  5. JohnWill

    JohnWill Retired Moderator

    Joined:
    Oct 19, 2002
    Messages:
    106,418
    What do you mean, "no luck"? What shows up in Disk Management?
     
  6. Peter23

    Peter23 Thread Starter

    Joined:
    Sep 22, 2007
    Messages:
    4
    It doesn't show up on disk management...
     
  7. JohnWill

    JohnWill Retired Moderator

    Joined:
    Oct 19, 2002
    Messages:
    106,418
    In that case, the hardware is not being recognized. When you plug it in, what appears in Device Manager?
     
  8. 07clarkm

    07clarkm Banned

    Joined:
    Jul 24, 2007
    Messages:
    624
    Wait! Did any drivers come with your external hard drive? I have seen a few now with drivers! :O
     
  9. JohnWill

    JohnWill Retired Moderator

    Joined:
    Oct 19, 2002
    Messages:
    106,418
    The WD Passport does not require any drivers.
     
  10. 07clarkm

    07clarkm Banned

    Joined:
    Jul 24, 2007
    Messages:
    624
  11. Xyzek

    Xyzek

    Joined:
    Oct 5, 2007
    Messages:
    42
    For future troubleshooting, I had this issue and fixed it by reassigning the drive letter in Diskmgmt.msc (in my case to Z:). I suggest trying this if the Disk Manager displays the USB drive, making sure you don't use a drive letter previously used by any other device.
     
  12. Alejandro_estrad

    Alejandro_estrad

    Joined:
    Nov 5, 2007
    Messages:
    1
    did you fixed you WD Passport? I have the same issue. I really need to recover my data!
     
  13. Bronto

    Bronto

    Joined:
    Aug 12, 2007
    Messages:
    15
    I have this problem also, same 160 WD drive. I was in a hurry and pulled it from a Mac without properly ejecting it. I'm thinking that Peter23 did something similar. After that I can't see it anywhere, but when I (uninstall a whole gang of drivers then) plug it in, it powers up, makes the bonk bonk noise, XP installs drivers and recognizes hardware, alerts that "new hardware found and ready to use", but the thing is still INVISIBLE. Note that the disk or drive letter cannot be seen in Disk Management, but the Device Manager lists WD under Disk Drives. It has no properties. Weird. And, it shows as WD in the Safely Remove Hardware app in the system tray.

    I have tried to find it using some of the disk management tools found on UBCD (such as trying to find or repair the MBR) but have had no luck. I would format it if I could see it somewhere. The only clue is the "WD" Device Driver.

    It's the invisible haunted Passport.
     
  14. rapid44

    rapid44

    Joined:
    Nov 11, 2007
    Messages:
    2
    I'm trying to use a WD Passport 250GB and is visible in Device Manager but is NOT in Computer Management and can not use it. I have been looking in WD support but the web site is not good and not helpful. Any ideas?
     
  15. Bronto

    Bronto

    Joined:
    Aug 12, 2007
    Messages:
    15
    So, the 250's do this too, eh?
     
  16. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/627870

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice