Website can't view "user" folders

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

gurutech

Thread Starter
Joined
Apr 23, 2004
Messages
2,960
I have a personal website set up, with several "users" folders, based off the main site.

Running Apache on Fedora 18. This worked fine on Fedora 17, but now, after the upgrade, followed by removing and reinstalling the httpd service, I can only view the main site. Had to reinstall due to configuration issues caused by the upgrade that were causing httpd to fail.

Now, anything following the main site, with a ~username path cannot be found. (404 error)

I've re-added the virtual directories and checked permissions, with a /home/*/public_html section, restarted the service, and even rebooted, but still not working.

Any ideas?
 

dvk01

Derek
Retired Moderator Retired Malware Specialist
Joined
Dec 14, 2002
Messages
56,452
are you using cpanel/WHM with that webserver

the default install of apache & cpanel comes with Apache mod_userdir Tweak enabled. that blocks http access to any folder with a ~ as start which stops the bandwith being used by other users

if you are using cpanel, then uncheck the Enable mod_userdir Protection under WHM/security center

Apache's mod_userdir allows users to view their sites by entering a tilde(~) and their username as the uri on a specific host. For example http://test.cpanel.net/~fred/ will bring up the user fred's domain. The disadvantage of this feature is that any bandwidth usage used by this site will be put on the domain it is accessed under (in this case test.cpanel.net). mod_userdir protection prevents this from happening. You may however want to disable it on specific virtual hosts (generally shared ssl hosts.)
 

gurutech

Thread Starter
Joined
Apr 23, 2004
Messages
2,960
are you using cpanel/WHM with that webserver

the default install of apache & cpanel comes with Apache mod_userdir Tweak enabled. that blocks http access to any folder with a ~ as start which stops the bandwith being used by other users

if you are using cpanel, then uncheck the Enable mod_userdir Protection under WHM/security center
Not sure what you mean by cpanel or WHM, but I checked my 00-base.conf file, and commented out the line for mod_userdir, and restarted the httpd service, but still can't access user directories.
 

gurutech

Thread Starter
Joined
Apr 23, 2004
Messages
2,960
Created an "Alias" using the line:
Code:
Alias   /~username  /home/username/public_html
and it worked, however I don't want to have to do this for several users.

How can I edit the httpd.conf file to avoid doing this?

Thanks in advance!
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Staff online

Top