Websites wont load properly on both chrome and safari ?

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

emalki

Thread Starter
Joined
May 24, 2020
Messages
4
Hi,

I've been having trouble opening amazon.com on both chrome and safari browsers, on chrome it shows me a gray information icon next to the website URL saying "your connection to this site is not secure", I tried following the instructions on the page, I tried deleting cookies and cache, I tried updating the software, nothing worked.
other amazon websites like .co.uk work just fine.
Masterclass.com will open but the videos won't load, whereas previously they did...
Please help, I've tried everything !!
 

plodr

Liz
Joined
Jun 27, 2014
Messages
20,752
You failed to mention the version of Windows and what browser or browsers you've tried.
 

emalki

Thread Starter
Joined
May 24, 2020
Messages
4
I'm using a Macbook pro, and the browsers I've tried are Chrome and Safari.
 

emalki

Thread Starter
Joined
May 24, 2020
Messages
4
I updated OS a few days ago hoping it would fix the problem, but it didn't.
I also tried disabling ad blockers and extensions as you suggested, no luck.


Disable any ad blockers and disable any Safari extensions and reboot
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Staff online

Top