When I connect m.2 it always boots to that

Warrior212

Thread Starter
Joined
Jul 16, 2020
Messages
1
My friend has a laptop which he doesn’t have admin account for as it was one for work but is no longer needed. It has an m.2 and he wanted me to clear everything on it so he can start from a fresh install of windows. However when I connect it to my pc it keep booting from it, in the bios it is the only option to boot from and I can’t see my hdd and ssd. When I disconnect it, it boots up normally from my ssd. How can I make it so it boots from my ssd and still have the m.2 connected so I can wipe it.
 
Joined
Feb 9, 2020
Messages
109
Get an M.2 to USB enclosure.

or

Boot to a USB/DVD Win 10 install, run Command Prompt -> Diskpart -> clean the M.2

or

Provide make/model of motherboard you are attaching this m.2 to, so as to try to determine what's going on with it at boot.

Most likely the M.2 slot being filled disables the SATA ports that your drives are plugged into. So another alternative is to move the drives to different SATA ports.
 

crjdriver

Moderator
Joined
Jan 2, 2001
Messages
41,363
Many high end motherboards have a utility built into the bios for secure erasing ssd/M.2 drives. Since I have no idea what motherboard you are running, I cannot tell you IF you have this option.

Use of diskpart to clean the drive is effective however you need to be absolutely sure of what drive you select. You would not be the first person nor will you be the last person to wipe the wrong drive.
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Staff online

Top