1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

wheres my safely remove icon gone

Discussion in 'Hardware' started by n133oyu, Apr 4, 2007.

Thread Status:
Not open for further replies.
Advertisement
  1. n133oyu

    n133oyu Thread Starter

    Joined:
    Jan 23, 2006
    Messages:
    17
    I have a toshiba laptop with Windows XP and SP2.

    I have noticed that the icon that comes up when i put a piece of hardware in my usb no longer appears, i have nothing to click on to safely remove any hardware.
    I normally use it for a mouse dongle, when i read up on another thread it says to look in my computer and click on the hardware and make some changes to it,however not being a storage device its not there.

    I have tried to use system restore to an earlier date but cannot go back further that 30 march (not far enough) even though there are lots of checkpoints.

    can anyone help please?

    kevin
     
  2. Blackmirror

    Blackmirror

    Joined:
    Dec 5, 2006
    Messages:
    32,641
  3. n133oyu

    n133oyu Thread Starter

    Joined:
    Jan 23, 2006
    Messages:
    17
    thank you blackmirror for your reply,

    i have followed the link copied the file to my desk top and double clicked and added this to the registry,rebooted but it still does not appear.
    ive tried with a camera in the usb but still no luck.
    in the mean time how do i safely remove the hardware without this.

    many thanks
    kevcab41
     
  4. Blackmirror

    Blackmirror

    Joined:
    Dec 5, 2006
    Messages:
    32,641
    Could you have a look in control panel .. system/ hardware /device manager/ for any yellow exclamation marks please
     
  5. Alex Ethridge

    Alex Ethridge

    Joined:
    Apr 10, 2000
    Messages:
    8,998
    I don't mean to sidetrack this thread; but, I've never used the disconnect procedure to disconnect a device unless it was storage media. Is there something about disconnecting a mouse, scanner or printer that I should know?
     
  6. bickster

    bickster

    Joined:
    Apr 4, 2007
    Messages:
    14
    Restoring the HotPlug Manager

    OK, so know we know that we're supposed to use the Safely Remove Hardware method to disconnect removable devices. But what happens if the Safely Remove Hardware icon goes AWOL on you? Or, what if you click it, but it doesn't do anything? And what if you already have phantom drives on your system? How do you get rid of them?

    The Safely Remove Hardware icon is actually a shortcut to Windows' HotPlug Manager. This service normally launches automatically when you connect a recognized USB or Firewire device to your system.


    Figure 1. The HotPlug Manager can be accessed via the Safely Remove Hardware icon, which normally appears in the Notification Area by the clock.

    But, as with all software, things sometimes go awry. The HotPlug Manager occasionally hangs or fails to launch, meaning that the Safely Remove Hardware icon won't appear, even when you know it should. In this case, the simple fix is to manually launch the HotPlug Manager by opening the Start, Run dialog and typing the following:

    RunDll32.exe shell32.dll,Control_RunDLL HotPlug.dll

    Click OK, and the HotPlug Manager's Safely Remove Hardware icon should appear. Its dialog box should open and display any connected devices. That's all it takes!

    If only it were so simple. Unfortunately, not all devices cooperate with the HotPlug Manager. If you connect an unrecognized device to your system and the Safely Remove Hardware icon doesn't appear — and manually launching the HotPlug Manager doesn't help — it may be that the device simply won't work with the HotPlug Manager. (It's not very common, but it happens.)

    I found this on windows secrets by Fred Langa. I hope it helps.
     
  7. n133oyu

    n133oyu Thread Starter

    Joined:
    Jan 23, 2006
    Messages:
    17
    yes i tried and a box appeared asking me to select the device i want to remove,however there were no devices listed even though i had my mouse dongle connected.

    and still no icon appeared on the quick launch panel.

    i have checked in my control panel/system/hardware/system devices no yellow check mark.
    the thing is my devices i connect are working ok its just that i dont want to shut down every time i want to disconnect.
    if it helps, when i connect anything to the usb i get the ding dong noise,so it is acknowledging the input.
    thanks
    n133oyu
     
  8. n133oyu

    n133oyu Thread Starter

    Joined:
    Jan 23, 2006
    Messages:
    17
    further to my last,

    it always used to work and i get the same problem with my camcorder and stills camera.
     
  9. bickster

    bickster

    Joined:
    Apr 4, 2007
    Messages:
    14
  10. Flags

    Flags

    Joined:
    Sep 9, 2001
    Messages:
    1,930
    Alex: Now you know.
     
  11. ~Candy~

    ~Candy~ Retired Administrator

    Joined:
    Jan 27, 2001
    Messages:
    103,706
    Right click on the task bar, go to properties, then customize and see if the icon has been set to 'always hide.'
     
  12. n133oyu

    n133oyu Thread Starter

    Joined:
    Jan 23, 2006
    Messages:
    17
    i have run the RunDll32.exe shell32.dll,Control_RunDLL HotPlug.dll thing and get the box up but no devices are listed. ive right clicked on the task bar properties/customise and the safely remove thing is there with a folder icon in past items, ive asked for never hide and its still not visible on tool bar.

    also looked at links given and says to do the above anyway

    thanks
     
  13. crjdriver

    crjdriver Moderator

    Joined:
    Jan 2, 2001
    Messages:
    37,260
    Since no device is listed when you run the hotplug mgr, I am wondering do the devices you connect in fact work? Are you having any problem other than the icon not displaying?

    FWIW the safely remove icon only flushes the cache; usb devices are designed to be connected and disconnected while the system is running. It does no damage to disconnect without using the safely remove icon [do wait a few seconds for all data to transfer]
     
  14. n133oyu

    n133oyu Thread Starter

    Joined:
    Jan 23, 2006
    Messages:
    17
    yes all my devices are working ok i even get the bing bong noise when i insert a device into the usb.

    thanks
     
  15. crjdriver

    crjdriver Moderator

    Joined:
    Jan 2, 2001
    Messages:
    37,260
    OK, here you go.
    With the external drive plugged in, right click the drive in the folders list, then left click Properties and Hardware. Left Click the name of the external drive in this list, then click Properties and Policies. This takes you to the "Write caching and safe removal page"
    Put a checkmark or click the safely remove hardware. This is from memory since I run vista so it might be called something different than properties and policies [I think that is what it is]
     
  16. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Similar Threads - wheres safely remove
  1. Serge2012
    Replies:
    2
    Views:
    108
  2. joe7dust
    Replies:
    5
    Views:
    342
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/558285

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice