Why can I not open MeWe.com in my Firefox browser?

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

beswickd

Thread Starter
Joined
Jul 22, 2007
Messages
64
For the last week I am unable to open MeWe.com in my Firefox browser even though it opens just fine in Microsoft Edge. When I click on the bookmark nothing happens and when I cop/paste the address from Edge, it just goes back to the page it was on. It refuses to move and I don't know what could be causing it.

Tech Support Guy System Info Utility version 1.0.0.9
OS Version: Microsoft Windows 10 Pro, 64 bit, Build 19042, Installed 20200529132248.000000-300
Processor: Intel(R) Core(TM) i7-5600U CPU @ 2.60GHz, Intel64 Family 6 Model 61 Stepping 4, CPU Count: 4
Total Physical RAM: 8 GB
Graphics Card: Intel(R) HD Graphics 5500, 1024 MB
Hard Drives: C: 476 GB (261 GB Free);
Motherboard: Hewlett-Packard 22FB, ver KBC Version 04.24, s/n PEZXT1BK99Q0B8
System: Hewlett-Packard, ver HPQOEM - 1, s/n 8CG5500NM2
Antivirus: Windows Defender, Enabled and Updated
 

cwwozniak

Chuck
Moderator
Joined
Nov 28, 2005
Messages
69,833
I am able to view https://mewe.com/ in my Firefox browser version 88.0.1 with no problems and using the AdBlocker Plus add-on. Is that exactly is what is showing in your Firefox address bar or are you ending up on another page on the site?

Are you getting a blank page or some kind of error message? If you are getting a blank page, what happens if you right-click inside the blank page and select "View page source"?
 

beswickd

Thread Starter
Joined
Jul 22, 2007
Messages
64
I am able to view https://mewe.com/ in my Firefox browser version 88.0.1 with no problems and using the AdBlocker Plus add-on. Is that exactly is what is showing in your Firefox address bar or are you ending up on another page on the site?

Are you getting a blank page or some kind of error message? If you are getting a blank page, what happens if you right-click inside the blank page and select "View page source"?
I get nothing at all. If I'm on my Homepage and I click on the link; nothing. If I copy/paste it into the address bar and hit enter, it goes right back to the page it's on.
 

cwwozniak

Chuck
Moderator
Joined
Nov 28, 2005
Messages
69,833
If you click on the link in my earlier post, are you saying that nothing at all happens and you are still on this Tech Support Guy page? If that is the case what happens if you right-click on the link and select "Open Link in New Private Window"?
 

plodr

Liz
Joined
Jun 27, 2014
Messages
24,738
Corrupt bookmark in Firefox?
Open it in Edge, copy the url.
Paste the url that opens into Firefox's address bar.
If it opens, replace the non-functioning bookmark with the new working bookmark.

I'm using FF 78.10.1 ESR and the page opens for me.
 

beswickd

Thread Starter
Joined
Jul 22, 2007
Messages
64
I am able to view https://mewe.com/ in my Firefox browser version 88.0.1 with no problems and using the AdBlocker Plus add-on. Is that exactly is what is showing in your Firefox address bar or are you ending up on another page on the site?

Are you getting a blank page or some kind of error message? If you are getting a blank page, what happens if you right-click inside the blank page and select "View page source"?
Sorry, I was sick all day yesterday. I did what you said and Firefox attempted to open MeWe in a new window but it never went beyond a black page with mewe.com in in address bar.
 

cwwozniak

Chuck
Moderator
Joined
Nov 28, 2005
Messages
69,833
Hope you are feeling better. I can't quite tell if you tried the two items below.

what happens if you right-click inside the blank page and select "View page source"?

If you click on the link in my earlier post, are you saying that nothing at all happens and you are still on this Tech Support Guy page? If that is the case what happens if you right-click on the link and select "Open Link in New Private Window"?
And, a new request. What happens if you restart Firefox with all add-ons temporarily disabled and try to access the page using the link in my earlier post?
 

beswickd

Thread Starter
Joined
Jul 22, 2007
Messages
64
Hope you are feeling better. I can't quite tell if you tried the two items below.






And, a new request. What happens if you restart Firefox with all add-ons temporarily disabled and try to access the page using the link in my earlier post?
I got the exact same result
Hope you are feeling better. I can't quite tell if you tried the two items below.






And, a new request. What happens if you restart Firefox with all add-ons temporarily disabled and try to access the page using the link in my earlier post?
I did as you said and disabled my pop-up blocker add on and I had the same result, a blank page. I tried right clicking on the blank page and nothing happened.
 

cwwozniak

Chuck
Moderator
Joined
Nov 28, 2005
Messages
69,833
I believe the latest stable version is Firefox version 88.0.1. Is that what you are running?

Before doing an unistall/reinstall try restarting Firefox in Troubleshoot mode (Menu: Help -> Troubleshoot Mode ... -> Restart). If the problem page seems to load OK, you probably have some add-on preventing the page to load and possibly blocking the right-click context menu.
 
Joined
May 24, 2021
Messages
6
I have version 88.0.1 and I have exactly the same problem that beswickd has described. Firefox completely ignores every request to go to MeWe.com. I can type it directly in and it never loads the page. It doesn't give any error, the tab title never changes from "New Tab" to "MeWe", and the view page source shows the default Firefox information that gets created from a fresh new tab.
 

cwwozniak

Chuck
Moderator
Joined
Nov 28, 2005
Messages
69,833
Hi, kirkdickinson, and welcome to TSG.

We normally request that members with the same problem start a new thread rather than add a "Me too" post in an existing active thread. Since I have not heard from beswickd for a little while, we can work on your problem here for now.

I have exactly the same problem that@ beswickd has described.
I just clicked on the link in my Post # 2 and get what appears to be the correct login webpage for MeWe with the title of "MeWe - The Next-Gen Social Network". Have you tried the link using troubleshooting mode in Firefox, as described in my post # 12?
 
Joined
May 24, 2021
Messages
6
Hi, kirkdickinson, and welcome to TSG.

We normally request that members with the same problem start a new thread rather than add a "Me too" post in an existing active thread. Since I have not heard from beswickd for a little while, we can work on your problem here for now.



I just clicked on the link in my Post # 2 and get what appears to be the correct login webpage for MeWe with the title of "MeWe - The Next-Gen Social Network". Have you tried the link using troubleshooting mode in Firefox, as described in my post # 12?
When I restart in troubleshooting mode and click on that link, at least the tab changes name from "New Tab" to "MeWe.com", but I am given a completely blank page and if I right click on the page to view page source or Inspect, the right click menu does not pop up

1621880040113.png.
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Members online

Top