1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Widnows 8.1 not running correctly.

Discussion in 'Windows 8' started by Dogwithhat, Jan 17, 2015.

Thread Status:
Not open for further replies.
  1. Dogwithhat

    Dogwithhat Thread Starter

    Joined:
    Jan 17, 2015
    Messages:
    1
    Have no idea where this belongs, but i'll guess with this one as I'm on windows 8.1.

    I got a new computer recently, and trying to access AMDs catalyst control center double clicked setup, after it had setup it restarted, on restart everything runs so slow so I can't connect to internet or use control panel properly, control panel runs super slow, and I can't seem to restore it to a previous restore point. Have tried running scans to fix it to no avail.
     
  2. DaveA

    DaveA Trusted Advisor Spam Fighter

    Joined:
    Nov 16, 1999
    Messages:
    16,301
    First Name:
    David
    What did you change when you accessed "AMDs catalyst control center"?
     
  3. Agye

    Agye

    Joined:
    Aug 27, 2014
    Messages:
    228
    did you try to add a preset when you were setting it up?
     
As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/1141371

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice