1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

wierd win98SE IDE to USB problems

Discussion in 'Hardware' started by poxyusernamehere, Jul 23, 2006.

Thread Status:
Not open for further replies.
  1. poxyusernamehere

    poxyusernamehere Thread Starter

    Joined:
    Jul 23, 2006
    Messages:
    1
    To my laymans understanding the problem Im having seems to lie with USBMonit.exe, and my 'USB Mass Storage Device' driver. Ive detailed the problem as best I can below. Obviously I would be very grateful for any direction anyone can offer on this as my own investigatory powers have found no solutions.

    my system:
    Win98SE on an AMD Athlon 2Ghzchipset
    device manager lists the following under USB controllers:
    -USB 2.0 Root Hub
    -USB Root Hub
    -USB Root Hub
    -USB Root Hub
    -VIA PCI to USB Enhanced Host Controller (IRQ 3)
    -VIA Tech 3038 PCI to USB Universal Host Controller (IRQ 11)
    -VIA Tech 3038 PCI to USB Universal Host Controller (IRQ 05)
    -VIA Tech 3038 PCI to USB Universal Host Controller (IRQ 10)
    device manager lists all of these as 'working properly'

    The Device:
    its an externally powered i-rocks 3.5" drive enclosure into which Ive placed a WesternDigital (WD800) IDE HDD set to 'master'. the drive is ~80gb & FAT32 with only 1 partition. This drive in this enclosure works fine on other machines (win98SE & winXP).

    The problem:
    When I power up & connect the enclosure for the first time my system detected the new hardware and installed "USB to IDE" and then "USB Mass Storage Device". The USBMonit.exe icon appeared in the system tray and remained there (same icon with green arrow) whilst the device worked perfectly, no problems at all. I could both read from and write to the drive large backup (*.tib) files. there was no indication anything was amiss. I disconnected the drive using "Safely Remove Hardware" and it disconnected with no errors. Then, When I tried to subsequently reconnect the drive the USBMonit.exe icon will appear for approx 20 seconds, and then disappear. no drive letter has been assigned. there is absolutely no activity read/write activity shown on the lights on the external drive during this time. rebooting does not help.

    A quick check of the device manager did not list the 'usb mass storage device' however, when I boot into safe mode, it IS listed. if I remove this device, reboot, and reconnect the drive, it is detected & installed as before and will work fine ONLY ONCE.

    Things ive already tried:
    support.microsoft.com/kb/q240075/ identifies a problem with USB on systems will 3 common aspects, AMD chipset > 350mhz, VIA tech USB controller, and win98SE. the article offers a patch (240075up.exe) to fix the problem, but it didnt change anything.

    usbman.com offers a 'compatibility update' for win98SE called (241134up.exe) which doesnt appear on support.microsoft.com this didnt change anything.

    usbman.com also offers an 'unofficial service pack' of which I installed the top 2 check boxes:
    Main Updates [all updates and hotfixes]
    Adaptec ASPI update 4.60.1021
    this also had no effect. The drive works fine ONCE, everytime I uninstall the Mass Storage Device driver.

    After installing each of these patches, I booted into safe mode and removed EVERY device listed under 'USB controllers', then rebooted and redetected the hardware before powering up the external drive.

    Possible solutions:
    Id like to avoid having to reinstall the OS if I can.
    Is there a way to simple uninstall the 'mass storage device' every time the system shuts down? This wouldnt be perfect, but at least 'workable'. It would mean the drive could be attached once per bootup.

    Thanks in advance for your help!!
     
As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/485582

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice