Win 2k - No PageFile

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

MajorModeler

Thread Starter
Joined
Jan 7, 2007
Messages
149
When booting up Windows 2000, after the login/password is completed, a notifier comes up saying there is insufficient virtual memory available. It describes how to set it using the My Computer properties. After saying o.k. to the notifier, Win 2k cycles back to the login screen, then to the insufficient virtual notifier, then back to the login and 'round and 'round we go.
Any thoughts on how to set the page file to be recognized? How about using another operating system? or DOS? or???
Thanks
 

MajorModeler

Thread Starter
Joined
Jan 7, 2007
Messages
149
Yes, it happens also in safe mode. SAme exact behavior.
I did try the 2000 repair from CD earlier. The response was something like: "The installed version is later than the CD. No attempt will be made." :-(

I have 2 gig real memory.
 

MajorModeler

Thread Starter
Joined
Jan 7, 2007
Messages
149
Another thought - this is on a dual boot system - the other is XP.
However, the partition designations ( C:, D:, S:, etc) are different between the 2 OSs. Is there a back door to change the win2K designations - that might work...
 

managed

Allan
Moderator
Joined
May 24, 2003
Messages
14,904
How much free space is there on the W2k partition ? Use Disk Management in XP to find out.

Also, how big is the pagefile.sys file on the W2k partition ?
 

MajorModeler

Thread Starter
Joined
Jan 7, 2007
Messages
149
3.76 gig free
no pagefile.sys.

Could I create a file and nameit pagefile.sys just to get started?
 

MajorModeler

Thread Starter
Joined
Jan 7, 2007
Messages
149
I created a pagefile.sys on the Win2K partition using Win XP.
the Pagefile.sys listing did not show up in the directory at 2meg size, the minimum, but it did show up at 10 meg size.
It appears that pagefile info is not loaded at boot time, but must be referenced somewhere in Win2K before booting. Any suggestions as to how / where to make this happen?
 
Joined
Sep 5, 2008
Messages
4
Startup Windows XP
Start |Run... |regedit
Double click HKEY_LOCAL_MACHINE
Select File |Load Hive...
Select ..\WINNT\system32\config\system from your Windows 2000 installation
Enter a temporary name such as W2K_System
(This will load the Windows 2000 system registry file under a new key W2K_System)
Double-click W2K_System
and go to
ControlSet001\Control\Session Manager\Memory Management
You should see there a value: PagingFiles
If you double-click it it should read something linke
C:\pagefile.sys 1024 1024

If it's not there you can create a new entry
It shoulde be a REG_MULTI_SZ (Multi-string value)
Right click |New |Multi-string value |PagingFiles |Enter |Enter
Fill in: C:\pagefile.sys 1024 1024
and press enter and then OK
(if you startup drive of Windows 2000 is not C you can change the driveletter to something different e.g. "D:\pagefile.sys 1024 1024")

You can double-check how the entry should look like on your Windows XP installation (HKEY_LOCAL_MACHINE\CurrentControlSet\Control\Session Manager\Memory Management\PagingFiles)

Click HKEY_LOCAL_MACHINE\W2K_System
Select File |Unload Hive...
Select Yes to unload it
Close regedit

Try to startup Windows 2000 to see if this helps.
 

MajorModeler

Thread Starter
Joined
Jan 7, 2007
Messages
149
Thanks Zalazar,
That looks like it should...
However, when I select Files, the Load Hive is greyed out and I can't make that selection.
 
Joined
Aug 7, 2007
Messages
9,028
Did you click HKEY_LOCAL_MACHINE first? That and HKEY_USERS are the only two trees that allow hives to be loaded under them.

HTH

Jerry
 

MajorModeler

Thread Starter
Joined
Jan 7, 2007
Messages
149
Thanks Jerry, for the reminder.
I apologize, Zalazar for not more closely reading your suggested procedure.
The end result was that the exhibited behavior was the same after I made the modification.
I think the missing piece is: Isn't there the drive partition to label - ie: partition 4 = Q: - somewhere in the registry? I think if I made that match the mappings that are in Win XP things should straighten up - at least the boot part.
Is there a way to tell what drive label Win2k thinks it is booting from? The boot.ini only has the partition number.
 

MajorModeler

Thread Starter
Joined
Jan 7, 2007
Messages
149
Curiouser and curiouser......
I do not believe that permissions are the issue because the properties window has only a general tab - no others, but the box that said "read only" was empty and it is shown as a type of system file. Keep in mind that this was using WinXP to look at them, as I cannot boot Win2k. The other tabs that are talked about in the link do not show up. The other interesting thing is that I have 4 pagefiles for WinXP, all on different partitions, including the Win2k partition, but only the two pagefiles that show up in a windows explorer window are the two that are 1 gig or larger. The two smaller ones - one on the WinXP partition, sized 2 meg; and the one on the Win2k partition, sized 10 meg, do not show up in the Windows explorer windows. All the partition view options are set to "show hidden files".
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Top