1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Win ME won't install scanner

Discussion in 'Earlier Versions of Windows' started by KRoyal, Jan 23, 2002.

Thread Status:
Not open for further replies.
  1. KRoyal

    KRoyal Thread Starter

    Joined:
    Aug 5, 1999
    Messages:
    4
    I have a Compaq Presario 5000, 320 megs RAM, Windows ME, Microtek Scanmaster 3630
    Windows ME has uninstalled my Microtek Scanmaker 3630 and installed (it thinks) the old scanner I had. However, since the proper drivers are not installed there is an exclamation point on the scanner in device manager.
    I have tried to uninstall this “no longer here” Umax scanner in device manager, but when I do either windows freezes up right after I click on "yes, I want to remove this device" or else after I do click on Yes it shuts down and restarts my computer. When it restarts, Windows comes back and says that my computer was not shut down properly, runs scandisk, and when I check device manger, sure enough the Umax scanner is still there.
    I tried shutting down, unplugging the device at the USB port and the electrical plug, plugging it back in, and restarting. Nothing happened. I then tried uninstalling the software for the Microtek scanner, unplugging the device at the USB port and electrical plug, then shutting down and restarting, reinstalling the software, shutting down again, and plugging the scanner back in, and then restarting. This resulted in device manager adding a USB composite device. I assume this is because Windows ME has detected the Microtek scanner but doesn't know what it is so it is attempting to put it somewhere. If I delete this USB composite device and restart, Windows puts it back.
    I have tried to install it manually, but Windows doesn't show any Microtek choices. Even though when I reinstalled the software it said it was updating the Microsoft database, I guess it didn't (or couldn't). If I try "have disk" it tells me that my CD for the scanner does not contain any information for the device. If I try telling it to use C:/windows/options/cabs - I get the same answer.
    When I noticed that my scanner was uninstalled I also saw that my Iomega Zip650 CD-RW was not there either. I did get it back and working by shutting down, unplugging it, plugging it back in, and restarting. Windows detected it and it is now working fine.
    I have two other USB devices, my keyboard and my Lexmark Z51 printer. They are working fine. When I boot up the computer, the light on the scanner does come on, so the scanner itself is working.
    Windows ME periodically uninstalls my printer, too, but I have not had any trouble reinstalling it.
    No changes have been made to my system since I last used the Microtek scanner.
    Anyone have any other ideas? I'm fresh out.

    Thanks
     
  2. bestshotdude

    bestshotdude

    Joined:
    Dec 26, 2001
    Messages:
    92
    Once upon a time I had a ComPaq computer with a mind of its' own and now with WinME trying to do even more of the thinking for you I have great sympathy for you. I don't know if this is possible or not as I think you might have to do a complete restore with the disks supplied by ComPaq but here is what I would try as a last resort. Uninstall all your USB devices as you have before but upon restart use your Sytem Restore or hopefully if ComPaq has gotten any more user friendly, bootup with the WinME disk. Save the current configuration and let it reload and hopefully since you have uninstalled all of your USB AND printer devices it will restore and not look for them untill you put them back on your system.
    ComPaqs are very independant and don't like a lot of extra stuff added to their OS and WinME makes it worse. You Might want to check before installing the devices if their are any new drivers at the manufacturer's sites and download them before installing it. Also, just for grins after each installation of a device restart the computer. And maybe do a scan disc and defrag before installing anything too. Hope this helps.
     
  3. KRoyal

    KRoyal Thread Starter

    Joined:
    Aug 5, 1999
    Messages:
    4
    I think I finally solved the problem. I was able to uninstall the errant Umax scanner in safe mode.
    However, I noticed in safe mode I had the Microtek scanner installed, as it should be, but in regular mode -- no Microtek scanner. Never did get a response from Microtek support and it's still under warranty -- I guess they don't - support their scanners, that is.

    It appears to be a bad USB port. Because the Iomega CD-RW was also uninstalled and Windows' penchant for periodcally uninstalling hardware, I was sure it was a Windows problem.

    Finally, I got the idea to switch USB ports. I put my Lexmark USB printer in the port I had been using for the scanner. No printer.

    Put the scanner in the port I had been using for the printer -- viola -- scanner works.

    My other 3 USB ports are working fine -- but that one is definitely dead.

    Thanks for all your help and suggestions.
     
As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/66066

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice