Winbook 10.1 key cover

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Aln10

Thread Starter
Joined
Jul 17, 2016
Messages
5
I have a Winbook TW100, 10.1" tablet which I upgraded to Windows 10. I recently purchased the Winbook 10.1 key cover -- which attaches to the tablet much as the Surface Pro key cover attaches to that tablet. But my Winbook will not recognize the key cover. I suspect the problem is that the key cover was to work with the original Windows 8 and that I need a new driver to make it work with Windows 10, but I cannot find any information online about any of this. I know this is a particular issue, but wonder if anybody here might have any experience with the Winbook.
 

Triple6

Rob
Moderator
Joined
Dec 26, 2002
Messages
52,933
What "key cover" did you buy? It likely uses Bluetooth for connectivity, did you connect them together?
 

Aln10

Thread Starter
Joined
Jul 17, 2016
Messages
5
It's actually called the Winbook 10.1 Key Cover -- It's not Bluetooth -- It connects to the Winbook the way the Surface Pro connects to its key cover, but with a different set of pins. The Winbook should recognize it as a USB device.
 

Aln10

Thread Starter
Joined
Jul 17, 2016
Messages
5
Yes, I tried contacting Microcenter, but their only suggestion was that I come into their store, which is 3,000 miles from my home.

The message I get from Windows 10 is that Windows failed to recognize a USB device. That's why I suspect I need a driver, if I could only find one.
 

Triple6

Rob
Moderator
Joined
Dec 26, 2002
Messages
52,933
Might be hard to do for these off brands. Is there any other model number anywhere on the cover or packaging? Stiff like this is generally re-branded stuff, another reseller may have drivers listed.

The failed to recognize device error message is usually a detection issue or faulty hardware, are the contacts clean and do they line up correctly?
 

Aln10

Thread Starter
Joined
Jul 17, 2016
Messages
5
The connectors all are clean and seem to line up correctly. Every time I disconnect and reconnect I get the "USB device not recognized" message -- The only marking on the keyboard reads "Model: K559
Made in China"
 

Triple6

Rob
Moderator
Joined
Dec 26, 2002
Messages
52,933
Found some pictures and sales info on that but no real support aside from one scam type driver software. I feel like it should just work with the built in Windows drivers for HID devices. Can you exchange it?
 

Aln10

Thread Starter
Joined
Jul 17, 2016
Messages
5
I suppose I'll be returning the key cover -- just thought I'd check in here first in case anybody could save me.

Thanks for your time.
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Members online

Top