1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Windows 7 will not regognise/run my ATI Catalyst and driver

Discussion in 'Windows 7' started by NeoMalfoy, Dec 26, 2010.

Thread Status:
Not open for further replies.
  1. NeoMalfoy

    NeoMalfoy Thread Starter

    Joined:
    Aug 15, 2007
    Messages:
    6
    The Title pretty much says it all been trying to get my graphic card (ATI Radeon x1600) to run properly with the Catalyst control center and drivers but widows only wants to use the Microsoft Corporation WDDM built in Divers (or that's what I am assuming they are)

    I have downloaded and tried to install the latest driver and catalyst software update from AMD (as of 12/13/2010) labeled AMD Catalyst 10.12 Preview for Windows 7– Featuring the new Catalyst Control Center

    and the ones found below that download and nothing.

    From http://sites.amd.com/us/game/downloads/Pages/radeon_win7-32.aspx

    and nothing after the reboot catalyst will not load I cannot find the programs exe to start it.

    I've tried updating the drivers though device manager it keeps saying the WDDM thingy is the best for it...
    I've run as admin also

    But as of right now I cannot run any games (save for ones from sites like bigfish and pogo) at all cause they tell me i need to update my drivers for the graphic card...

    I did not have this problem when I was running win XP or Win 2000 on this system (nothing has changed except windows 7 is now on...)

    My Specs are:
    Tech Support Guy System Info Utility version 1.0.0.1
    OS Version: Microsoft Windows 7 Professional , 32 bit
    Processor: Intel(R) Pentium(R) Dual CPU E2140 @ 1.60GHz, x64 Family 6 Model 15 Stepping 13
    Processor Count: 2
    RAM: 1535 Mb
    Graphics Card: Radeon X1600 Series (Microsoft Corporation - WDDM) , 256 Mb
    Hard Drives: C: Total - 305234 MB, Free - 123618 MB; D: Total - 238472 MB, Free - 98304 MB; G: Total - 476937 MB, Free - 81478 MB;
    Motherboard: ASUSTeK Computer INC., Lancaster8, 1.xx, X312345678
    Antivirus: avast! Antivirus, Updated and Enabled
     
  2. RaytheBear

    RaytheBear

    Joined:
    Sep 13, 2010
    Messages:
    628
    Yeah, that is one problem of trying Preview Drivers (I guess Preview is a new fancy name for Beta) you could run into some problems and one has to play around with it to get it working properly.

    Good luck
    Ray
     
As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/970836

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice