1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Solved Windows 98 SE Hangs on Startup at Logon Screen

Discussion in 'Earlier Versions of Windows' started by ryanhe, Jan 26, 2018.

Thread Status:
Not open for further replies.
Advertisement
  1. ryanhe

    ryanhe Thread Starter

    Joined:
    Jun 5, 2007
    Messages:
    109
    Well, I jinxed myself last night...

    Been playing around with an old Thinkpad 770X and used Win98SE recovery discs from a T20 to bring the system back to life.

    I was installing some games and thought to myself, "this is going really well". I installed Quake II, MS Entertainment Puzzle Pack and then Age of Empires II... without restarting as recommended in between (forgot that Win9x likes to be restarted after any and every little thing). AOE2 required a restart and thats when things went wrong....

    Upon restart, I got to the logon screen and the system just hung there until I hit the power switch. Restarted and tried Ctrl-Alt-Del and it said MSGSRV32 wasn't responding.

    Shut it down again, booted in safe mode and turned off all startup items in msconfig and turned off autoexec.bat, config.sys, and system.ini (win.ini was grayed out). Rebooted and it still hung in the same place.

    Booted with a bootlog and it showed a bunch of font load failures (ttf not fon) LoadError 0016

    Not sure why failing to load fonts would cause the whole system to hang but if there's no other fix, it won't be too much of a pain to reformat and start again but I figured I'd try everything else before going to extremes.
     
  2. lunarlander

    lunarlander

    Joined:
    Sep 21, 2007
    Messages:
    9,209
    If I remember correctly, fonts were critical in Windows.
     
  3. ryanhe

    ryanhe Thread Starter

    Joined:
    Jun 5, 2007
    Messages:
    109
    That would make sense given the situation. I'll try copying the fonts over at a DOS prompt then and see what happens.
     
  4. ryanhe

    ryanhe Thread Starter

    Joined:
    Jun 5, 2007
    Messages:
    109
    Well, I'm not sure what the actual issue was but I followed the steps in Q234749 to restore the fonts and then got the GDI.exe not found must restart windows error so I just reformatted and reinstalled...
     
As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/1203656

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice