1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Windows 98 SE install and COM Ports

Discussion in 'Earlier Versions of Windows' started by jglong3, Sep 16, 2004.

Thread Status:
Not open for further replies.
  1. jglong3

    jglong3 Thread Starter

    Joined:
    Jul 23, 2003
    Messages:
    141
    Hello,,, :) :)

    Thanks for your help and advice!!!!!

    Tried to find this situation in archives and via GOOGLE.
    I apologize if there is an article in this forum that describes this!

    The system is old and surprisingly is running GREAT using W98SE:

    o Packard Bell Legend 822 CDT ( Purchased in 1995)
    o 32 MB RAM (originally 16MB)
    o PB 600 MotherBoard with 100 MHZ Pentium(r) processor
    o Windows 98SE (originally Windows for Workgroups 3.1, Dos 6.2)
    o BIOS upgraded to 1.2, all original devices were found on
    re-boot and working as expected
    and-
    CMOS was NOT reset to default.
    o Aztech Sound Galaxy (Wahsington 16 chipset)

    The sound board is working properly.
    The sound board has a Rockwell Modem (14.4 AMSP) on COM1 (IRQ4)
    The internal Rockwell Modem works as expectecd under W98SE.

    Situation:

    Under Windows for Workgroups 3.1:

    o Internal Modem on COM1 IRQ 4 (as expected)
    o External Modem on COM2 IRQ 3 (as expected)

    After Installing Windows 98 SE:

    o Internal Modem on COM1 IRQ 4 (as expected)
    o External Modem on COM3 IRQ 4 (Not expected, COM2 expected)

    While the 3.1 system was still being used an external modem "Diamond
    SupraExpress 56e V.90 SUP2730" was connected to the DB9 serial
    port (COM2 I think????), configured, and worked as expected
    under 3.1 and still works under W98SE.

    However, under Window 98 SE the modem DIAGNOSTICS do not work and produces the ERROR: "Already in USE." for either modem, unless the external modem is removed. This is what forced a check using W98SE DEVICE MANAGER for these two devices and found now they are both using the same IRQ (4), The internal modem on COM1 and now the external modem is on COM3.

    On the older 3.1, if I remember correctly, I thought the DB9 serial connector was on COM2 (IRQ3), but on the W98SE it is on COM3 (IRQ4), and the Internal Rockwell modem is on COM1 (IRQ4), which is the same IRQ.

    There are no conflicts reported by DEVICE MANAGER (???) and both
    modems work as expected, but obviously only one at a time since
    they both have the same IRQ. And, this is the problem. I would like
    to use both modems if possible and at the same time,,,,(two seperate
    telecom lines are available).

    SO, here is what I tried under W98SE:

    Using DEVICE MANAGER and once on the COM3 port I
    reset the USE AUTOMATIC SETTINGS. The CHANGE SETTING was
    selected for the COM3 port and the following error was displayed:

    THIS REASOURCE SETTING CANNOT BE MODIFIED.

    Tried using "SETTING BASED ON.....", but any selection presented
    the same error: "THIS REASOURCE SETTING CANNOT BE MODIFIED". Or a selection was allowed but the setting but produced reported conflicts (IRQ or
    INPUT/OUTPUT RANGE ADDRESS).

    Thought that IRQ STEERING may have some effect so I turned IRQ
    STEERING off and the same things occured.

    The sound card with the internal modem is plugged in an ISA bus on a
    riser card off the MotherBoard.

    ,,,,,I removed the external modem plus removed all it's drivers
    and rebooted. The SOUND CARD and its internal modem was
    ok after a boot and set to the expected COM1 IRQ 4. Then I powered
    off the machine again, set up the external modem using the DB9 serial
    connector (straight off the MotherBoard) and it configured using the
    MODEMs CD for driver delivery and occured as expected, but it was back to
    COM3 and IRQ 4 again(????)!!!!!

    In the past (Windows 3.1) it seems like the DB9 serial connector was on
    COM2 before W98SE, but I cannot remember?????? Now, since W98SE was
    installed it is on COM3(????).......

    Or, there might be a jumper to force the DB9 serial connector to be interpreted as COM2 when using Windows 3.1, but under W98SE is seeing the jumper as COM3(?????)

    It is strange that the DB9 connector is set up on COM3 with the same
    IRQ as COM1 and W98SE does not report a conflict(???)..........?

    Any insite and advice would be great.


    One good thing happened---- Turning off IRQ STEERING allowed the
    "SHUT DOWN" to work with the message:

    " YOU CAN NOW POWER OFF THE COMPUTER"

    Just after W98SE was installed ( a long time ago) the computer would hang at the well known BLACK SCREEN if SHUT DOWN was selected. And, since this revelation, I found that Microsoft Knowledge Base Article- 238096 discusses this very situation with IRQ STEERING and SHUT DOWN.


    Thank you for your time, help, and advice! :) :)

    Jerry
     
  2. jglong3

    jglong3 Thread Starter

    Joined:
    Jul 23, 2003
    Messages:
    141
    Hello,,,,

    Problem Solved:

    The following corrected the situation:

    A. Under Windows 98SE DEVICE MANAGER was used to:

    1. Under COM Ports: REMOVED the COM3 device
    2. Under Modems: REMOVED the external modem that
    was on COM3
    NOTE: Did not physically remove the
    external modem.
    Did not remove the drivers
    for this external DIAMOND
    SUPRA EXPRESS modem.
    3. Rebooted the system.

    W98SE found the external modem and reconfigured
    the external modem to use COM2 (IRQ3).

    Also, W98SE did define COM3 (IRQ4) but with
    COM3 empty.

    System runs as expected and both modems can now be used at the same
    time by using two seperate land lines.

    The following could not be used to solve the situation:

    B. The PHOENIX BIOS Version 4.04 AGOURA Release 1.20 in
    this PB 600 MotherBoard does not allow COM ports to be
    modified. Or, if it does a method could not be found to do so.
    Also, the DEVICE MANGER in W98SE would not allow the COM
    ports to be modified producing:

    THIS REASOURCE SETTING CANNOT BE MODIFIED.

    No matter if the RESOURCES tab setting for
    USE AUTOMATIC SETTINGS was turned off.

    If you spent any time looking at this issue, many thanks!!!!!! :) :)

    I apologize for a lengthy description, and after looking at it, it seemed to be hard to follow!!!! :-( ;-|

    Jerry
     
As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/274699

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice