Windows Explorer impossibly slow when highlighting files

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

whitehound

Thread Starter
Joined
Aug 17, 2006
Messages
116
Hello. I hope somebody can help me with a Windows Explorer problem. I've tried searching for a solution on the net but whenever I put the search terms in I am overwhelmed with articles about how to fix folders which are slow to load when opened - which is not the issue.

All my folders load very rapidly, so that's fine. The problem comes when I want to select and drag files within the folders - especially but not solely graphics files. It goes like this.

I eyeball the list of files I want to highlight, and click on the top or bottom one. Then I go away and read a book for two or three minutes until the cursor comes back to life. Then I go back into Explorer and highlight the file at the other end of the group, and then I go and read a book for two or three minutes until Explorer deigns to highlight the group, Then I try to click and drag on it, and the cursor turns into an hourglass. Then I go and read a book for around ten minutes, then try again, and if I'm lucky, finally it moves and copies to where I want it. If not, I read another chapter.

When I was using Windows 7 I used to back up every one or two nights. Now that I'm on Windows 10 I only backup about once in ten days, because instead of being able to copy any updated files in around three minutes, I now have to set aside around an hour and a half.

Right-clicking on individual files to bring up the list of options also takes an extraordianrily long time, though not as long as highlighting does. Once the menu has appeared, though, it performs its actions at normal speed.

Despite what it says in the sysinfo below, btw, my antivirus is AVG.

Tech Support Guy System Info Utility version 1.0.0.4
OS Version: Microsoft Windows 10 Pro, 64 bit
Processor: Intel(R) Pentium(R) CPU G2020 @ 2.90GHz, Intel64 Family 6 Model 58 Stepping 9
Processor Count: 2
RAM: 8085 Mb
Graphics Card: Intel(R) HD Graphics, -1984 Mb
Hard Drives: C: 930 GB (769 GB Free); E: 1862 GB (1489 GB Free);
Motherboard: Gigabyte Technology Co., Ltd., H61M-DS2 DVI
Antivirus: Windows Defender, Disabled
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Staff online

Top