1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Windows Explorer mouse right click

Discussion in 'Windows 7' started by hgormley, Feb 15, 2013.

Thread Status:
Not open for further replies.
Advertisement
  1. hgormley

    hgormley Thread Starter

    Joined:
    Feb 15, 2013
    Messages:
    3
    Windows Explorer Mouse right click –not responding --Windows 7 Home Premium SP1 Dell 520 Memory 3Gb


    When I right click on a folder to copy or paste Windows Explorer shows “not responding” rather than the right click menu --it then blinks and disappears.

    I have tried the usual suggested solutions such as Scannow, Malware Antivirus, updated Drivers, changed mouse, changed keyboard even as far as an “in place upgrade” –all to no avail.
    In addition I have run Hard Drive scans a number of times and Memory Diagnostics but still no solution.

    I am using Multiboot with Vista, Windows 8 and Windows 7. Both the Vista and Windows 8 Windows Explorer work fine.

    As well as Windows Explorer I also use Power Desk 7 and XYplorer and when I use these in Windows 7 installation they also fail to respond to the mouse right click and they disappear in the process.

    When I right click on “Windows 7 C drive the correct menu is shown but when I go to one of its folders the failures begin.

    I would appreciate any advice preferable not a full reinstall.

    HGormley
     
  2. ETech7

    ETech7

    Joined:
    Aug 30, 2012
    Messages:
    893
    Did it start after some changes been made to the system (instal/uninstall software/hardware, registry cleaning, virus removal...)? Did you try to removing XYplorer?
     
  3. hgormley

    hgormley Thread Starter

    Joined:
    Feb 15, 2013
    Messages:
    3
    Thank you for your prompt reply.
    I have installed various softwares from time to time but have not kept a specific record.
    With regard to Xyplorer I have uninstalled it as you suggest but the problem still persists.
     
  4. lunarlander

    lunarlander

    Joined:
    Sep 21, 2007
    Messages:
    11,118
    Try System Restore to a previous date.
     
  5. hgormley

    hgormley Thread Starter

    Joined:
    Feb 15, 2013
    Messages:
    3
    Thank you for your reply.
    I have tried System Restore but I think it is probably about 6 weeks since the fault arose.
     
  6. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/1089669

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice