Windows Host Process has stopped working

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

MSwan

Thread Starter
Joined
May 23, 2010
Messages
2
So I keep getting this problem where Windows Host Process stops working, followed very quickly by windows audio service.

Exact Message: Host Process for Windows Services stopped working and was closed. A problem caused the application to stop working correctly. Windows will notify you if a solution is available.

I have a Dell Studio 1440 running Windows Vista 64 bit.

For the past couple months I've been having this problem with popping sounds from my audio, usually when I'm playing games or watching things, though sometimes just randomly. This was occasionally followed by the host process stopping working, now it happens more often. It also happens whenever I access some games such as Warcraft III Frozen Throne.
 
Joined
Sep 21, 2009
Messages
1,312
What is the make and model of your computer?

Are you using the most recent drivers for your audio card?
 

MSwan

Thread Starter
Joined
May 23, 2010
Messages
2
The computer is a Dell Studio 1440, and yeah, going to the Dell Support driver download was the first thing I tried. I reinstalled it several times.
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Top