1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Windows installer problem

Discussion in 'Windows XP' started by soulcrew2001, Jan 27, 2007.

Thread Status:
Not open for further replies.
Advertisement
  1. soulcrew2001

    soulcrew2001 Thread Starter

    Joined:
    Jul 17, 2004
    Messages:
    48
    I have just formated a dell 510m inspiron notebook with XP SP2 and after several problems with drivers, and a lot of help from you guys, I am now back online. After running windows update I noticed there was one update that wouldnt install (windows installer 3.1). Now, any programs downloaded from the net wont install. eg. firefox, realplayer, avg....the list goes on. I have tried to uninstall and repair but to no avail?!!? Can anybody help me......I/m starting to think this format was a bad idea.

    PS when I installed windows i partitioned the drive, one 10G & one 30g. Windows is on the 10g drive and the other drive is yet to be formatted. Is this anything to do with the problem?

    Many thanks
     
  2. Flrman1

    Flrman1

    Joined:
    Jul 26, 2002
    Messages:
    46,329
    Go here and download the Windows Installer package. Save it to your desktop and try installing it. I've seen this problem solved this way before. I think in some cases the installation was only successful when done in safe mode so you may want to boot to safe mode and try the installation from there.
     
  3. soulcrew2001

    soulcrew2001 Thread Starter

    Joined:
    Jul 17, 2004
    Messages:
    48
    Tried in safe mode, stopped installing on msi.dll, unable to find folder...etc. I did try this earlier in normal mode and it stopped in a simlar way only that tiome it was a different file, msiexe. something or other....any other suggestions, this problem seems pretty difficult.
     
  4. Rich-M

    Rich-M

    Joined:
    May 3, 2006
    Messages:
    22,443
  5. soulcrew2001

    soulcrew2001 Thread Starter

    Joined:
    Jul 17, 2004
    Messages:
    48
    Still no good, I have downloaded all the different fixes and none seem to work, it now gets stuck on update\update.exe is not a valid win32 application when trying to extract
     
  6. soulcrew2001

    soulcrew2001 Thread Starter

    Joined:
    Jul 17, 2004
    Messages:
    48
    i didnt do chipset for motherboard as there were no yellow question marks. Where do i find out my current chipset?
     
  7. soulcrew2001

    soulcrew2001 Thread Starter

    Joined:
    Jul 17, 2004
    Messages:
    48
    I am now downloading the whole sp2 update 266mb!! Could this fix it?? I doubt it!!
     
  8. soulcrew2001

    soulcrew2001 Thread Starter

    Joined:
    Jul 17, 2004
    Messages:
    48
    SP2 pack wont install again either, what do I do, I cant remove IE6, what is wrong with windows installer just after a reformat with a genuine windows disk???
     
  9. Rich-M

    Rich-M

    Joined:
    May 3, 2006
    Messages:
    22,443
    If your disk has SP2 on it, you won't be able to reinstall Sp2.
    Go to Dell site and put in service tag # on laptop to get to drivers...you will see chipset driver amongst them
     
  10. soulcrew2001

    soulcrew2001 Thread Starter

    Joined:
    Jul 17, 2004
    Messages:
    48
    I have done this already but have now done it again, still the same...............
     
  11. Rich-M

    Rich-M

    Joined:
    May 3, 2006
    Messages:
    22,443
    Only other choice is to try XP repair:
    http://www.michaelstevenstech.com/XPrepairinstall.htm
    If this doesn't do it, the only other choice would be reformat (make sure you do not choose quick format) and do XP, the mobo drivers , then every Windows Update (do manually from Start Menu and refuse nothing (except video and modem drivers).
     
  12. soulcrew2001

    soulcrew2001 Thread Starter

    Joined:
    Jul 17, 2004
    Messages:
    48
    Have done xp repair now, no difference...........
     
  13. limpalong

    limpalong

    Joined:
    Jan 28, 2007
    Messages:
    1
    I have tried the non-destructive re-install suggested here for XP Pro SP2. It has worked on 3 other computers I did with no problems. On my personal pc I am getting KB893803 v2 -x86.exe Setup error Access Denied. I am logged in as admin. Tried in safe mode with the same result.

    I checked the msi.dll file version as suggested in this thread and found mine is v3.0.3790.2180. Can I rename msi.dll to msi.old, copy in a newer version from another computer and try the 3.1 installer again?

    I haven't formated the hard drive in over a year so it is way past time but didn't want to take the entire weekend and more to do it.

    As an aside, when I clicked on the link to chipset driver posted by Rich M in this thread, I was taken to a website for Zionbank.com. What's that about???

    Thanks
     
  14. Rich-M

    Rich-M

    Joined:
    May 3, 2006
    Messages:
    22,443
    Sorry i didn't post a link to chipset driver...I posted a link to a Ms support page that I justtried and it still works.
     
  15. bbearren

    bbearren

    Joined:
    Jul 14, 2006
    Messages:
    3,775
    I would run chkdsk /r

    Then I would run sfc /scannow
     
  16. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/538938

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice