Windows Installer PROBLEM!

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

wil919

Thread Starter
Joined
Oct 10, 2008
Messages
5
Hello everyone; it's been awhile!
I hope this message finds you all well; I posted this months ago in a different forum, but I received little to no help. hopefully someone here can help me!!

Recently, I've come across the problem that I believe has to do with my Windows Installer. I've noticed that whenever I turn on my computer, this pop-up message from Windows Installer comes up on the boot up as Windows is done loading all of my programs. Also, this pop-up message comes up when I try to install certain programs, such as Blackberry Desktop Software, and then immediately terminates the install from there on out. The message says exactly as follows:

____
Windows ® Installer. V 4.5.6001.22159

msiexec /Option <Required Parameter> [Optional Parameter]

Install Options
</package | /i> <Product.msi>
Installs or configures a product
/a <Product.msi>
Administrative install - Installs a product on the network
/j<u|m> <Product.msi> [/t <Transform List>] [/g <Language ID>]
Advertises a product - m to all users, u to current user
</uninstall | /x> <Product.msi | ProductCode>
Uninstalls the product
Display Options
/quiet
Quiet mode, no user interaction
/passive
Unattended mode - progress bar only
/q[n|b|r|f]
Sets user interface level
n - No UI
b - Basic UI
r - Reduced UI
f - Full UI (default)
/help
Help information
Restart Options
/norestart
Do not restart after the installation is complete
/promptrestart
Prompts the user for restart if necessary
/forcerestart
Always restart the computer after installation
Logging Options
/l[i|w|e|a|r|u|c|m|o|p|v|x|+|!|*] <LogFile>
i - Status messages
w - Nonfatal warnings
e - All error messages
a - Start up of actions
r - Action-specific records
u - User requests
c - Initial UI parameters
m - Out-of-memory or fatal exit information
o - Out-of-disk-space messages
p - Terminal properties
v - Verbose output
x - Extra debugging information
+ - Append to existing log file
! - Flush each line to the log
* - Log all information, except for v and x options
/log <LogFile>
Equivalent of /l* <LogFile>
Update Options
/update <Update1.msp>[;Update2.msp]
Applies update(s)
/uninstall <PatchCodeGuid>[;Update2.msp] /package <Product.msi | ProductCode>
Remove update(s) for a product
Repair Options
/f[p|e|c|m|s|o|d|a|u|v] <Product.msi | ProductCode>
Repairs a product
p - only if file is missing
o - if file is missing or an older version is installed (default)
e - if file is missing or an equal or older version is installed
d - if file is missing or a different version is installed
c - if file is missing or checksum does not match the calculated value
a - forces all files to be reinstalled
u - all required user-specific registry entries (default)
m - all required computer-specific registry entries (default)
s - all existing shortcuts (default)
v - runs from source and recaches local package
Setting Public Properties
[PROPERTY=PropertyValue]

Consult the Windows ® Installer SDK for additional documentation on the
command line syntax.

Copyright © Microsoft Corporation. All rights reserved.
Portions of this software are based in part on the work of the Independent JPEG Group.
______

I don't know exactly what this message means, but I know it is preventing me from installing certain programs on my Dell Inspiron 9300. Please please please help! I haven't a clue of what to do, and I've tried searching everywhere on Google to locate a resolution to no avail :(

I've already tried updating Windows Installer, but that didn't work.

Any help would be GREATLY appreciated; thanks!
 

wil919

Thread Starter
Joined
Oct 10, 2008
Messages
5
ok, I just tried this.

an error pops up when I try to merge that says:

"Registry Edior:
Cannot import C:\Documents and Settings\MY NAME\Desktop\msii1.reg: Error accessing the registry."

Hmm... now what?
 

Frank4d

Retired Trusted Advisor
Joined
Sep 10, 2006
Messages
9,126
You need to run the REG file while logged onto an account with administator privileges.
 

wil919

Thread Starter
Joined
Oct 10, 2008
Messages
5
I only have one account on this computer, and that is mine. It is an administrator account (or so I thought). Is there any way to change that to fix that, or should I try it in Safe Mode?
 
Joined
May 7, 2006
Messages
1,763
Try entering into the registry a test key.

Either type or 'Copy and Paste' (preferably) the following in notepad or some other text editor.

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\testkey]
"TestDword"=dword:00000000
"TestString"="testing"

[HKEY_LOCAL_MACHINE\SOFTWARE\testkey\testsubkey]

Then save the file to the desktop with a name such as Test key and with an .reg extension.

Example: Test Key.reg

Right click on the file and select 'Merge'.

Or download the this attachment and change the .txt extension to .reg

Then double click on it and see if it will be added to the registry. This will not in anyway alter your registry for it is a meaningless test key. You can always open regedit and navigate to the key and delete it.
 

Attachments

wil919

Thread Starter
Joined
Oct 10, 2008
Messages
5
Ok, I went ahead and did that and the test key was added successfully to the registry.
 
Joined
May 7, 2006
Messages
1,763
If the test key took OK then it could be a corrupt download .reg file.

Try this:

Go here: http://www.dougknox.com/

In the left column click on 'Win XP Fixes.

Scroll down and click on 'File Association Fixes'.

Click on 'MSI FIle Association Fix'

Save it to your download folder and extract to the desktop. Double click on it and see if it will take.
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Top