1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Windows not recognizing USB HD

Discussion in 'Hardware' started by mousenblack, Dec 27, 2007.

Thread Status:
Not open for further replies.
  1. mousenblack

    mousenblack Thread Starter

    Joined:
    Dec 27, 2007
    Messages:
    1
    I have a Dell XPSP2 I'd like to plug in my Seagate FreeAgent Go USB to. The drive does not show on the system. When I goto Add Hardware Wizard it does show and says the device is working properly when plugged into the USB on motherboard. I recently received this unit from a friend and formated with factory install and installed updates, added Seagate st340810A as a slave a Compaq DVD-ROM and a generic USB 2.0 all from my old Presario. When I plug into the PCI USB 2.0 the unit finds an unrecognized device then something like, “...one of the devices...has malfunctioned...” and it's disconnected and I can unplug it. I've been using the FreeAgent on my MacOSX and might have deleted some XP software? Or maybe the USB PCI is bad, or most likely I don't have a clue how to use Windows and all this right click stuff.
     
As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/665328

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice