1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Windows won't boot if SVM is enabled

Discussion in 'Hardware' started by packetgod, Sep 4, 2019.

  1. packetgod

    packetgod Thread Starter

    Joined:
    Sep 4, 2019
    Messages:
    2
    So I had built a system in order to study/practice for my IT certifications, one of my main goals was to be able to use it for virtualization. The specs are as follows;

    Tech Support Guy System Info Utility version 1.0.0.4
    OS Version: Microsoft Windows 10 Pro, 64 bit
    Processor: AMD Ryzen 5 2400G APU with Radeon Vega Graphics, AMD64 Family 23 Model 17 Stepping 0
    Processor Count: 8
    RAM: 14265 Mb (2x8gb)
    Graphics Card: AMD Radeon(TM) RX Vega 11 Graphics, -2048 Mb
    Hard Drives: C: 465 GB (376 GB Free);
    Motherboard: ASUSTeK COMPUTER INC., ROG STRIX B450-F GAMING
    Antivirus: Windows Defender, Enabled and Updated

    As the title says, I tried to enable SVM but then Windows booted into the recovery screen.
    I restarted, disabled SVM, booted OK
    Updated CPU drivers, and BIOS firmware to the latest (2704)
    I enabled SVM one more time, but Windows could not boot, it restarted 3 times and finally went to the recovery screen again.
    I went back to BIOS, turned off SVM and loaded Windows OK.

    Looking around the internet, it was frightening to see others with the Ryzen 5 2400g APU having the same exact issue with no solution.

    Will somebody please help or explain why this could be happening? Thank you!
     
  2. lunarlander

    lunarlander

    Joined:
    Sep 21, 2007
    Messages:
    11,578
    You don't need BIOS's SVM to build a virtual machine. Just download Oracle's free VirtualBox. It will allow you to install any OS on top of Win 10. You can run that 'guest' OS anytime or shut it down. When the 'guest' OS runs, it will run in a window.
     
  3. packetgod

    packetgod Thread Starter

    Joined:
    Sep 4, 2019
    Messages:
    2
    Hi thanks, but I'd prefer to fix the issue and experiment with different VM providers as this is for an educational purpose.

    It looks like disabling the IOMMU (Input-Output Memory Management Unit) setting in the bios let's Windows 10 boot normally, and Hyper V works well as well. Even though IOMMU sounds like a desirable feature to leave enabled, I'll have to do some research on that.

    Cheers!
     
As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...

Short URL to this thread: https://techguy.org/1232529

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice