Windows XP boot looping on Compaq Laptop

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

rhys898

Thread Starter
Joined
Jan 4, 2011
Messages
3
Hi All,

Have a Compaq Presario C304NR Laptop that is stuck in a boot loop. I have pulled the hard drive and scanned for malware and virus' and checked for disk errors using chkdsk /r on another machine. I used the windows debug tool to read the minidump and these are the results:

*******************************************************************************
* *
* Bugcheck Analysis *
* *
*******************************************************************************
BAD_POOL_CALLER (c2)
The current thread is making a bad pool request. Typically this is at a bad IRQL level or double freeing the same allocation, etc.
Arguments:
Arg1: 00000043, Attempt to free a virtual address which was never in any pool
Arg2: e0722000, Address being freed.
Arg3: 00000000, 0
Arg4: 00000000, 0
Debugging Details:
------------------

FAULTING_IP:
nt!CmpFree+17
80632cd7 5d pop ebp
BUGCHECK_STR: 0xc2_43
CUSTOMER_CRASH_COUNT: 7
DEFAULT_BUCKET_ID: COMMON_SYSTEM_FAULT
PROCESS_NAME: logonui.exe
LAST_CONTROL_TRANSFER: from 8054386d to 804f8cc5
STACK_TEXT:
b9e1d9bc 8054386d 000000c2 00000043 e0722000 nt!KeBugCheckEx+0x1b
b9e1d9fc 80544a1d e0722000 e176f620 e1787000 nt!MiFreePoolPages+0x8b
b9e1da3c 80632cd7 e0722000 00000000 b9e1daa8 nt!ExFreePoolWithTag+0x1b7
b9e1da4c 806358f0 e0722000 00001000 00000000 nt!CmpFree+0x17
b9e1daa8 80635cd5 e1beb4c8 00000000 00000000 nt!HvpRecoverData+0x3ec
b9e1daf4 806275e4 e1beb4c8 00000000 00000001 nt!HvMapHive+0x133
b9e1db0c 8062f167 e1beb501 00000005 00000000 nt!HvInitializeHive+0x416
b9e1db78 8061c7b5 b9e1dbb4 00000005 00000000 nt!CmpInitializeHive+0x273
b9e1dbd0 8062195b b9e1dd04 00000000 b9e1dc64 nt!CmpInitHiveFromFile+0xa3
b9e1dbf8 80628ca8 b9e1dccc b9e1dc6c b9e1dc5c nt!CmpCmdHiveOpen+0x21
b9e1dcac 8061c370 b9e1dce4 b9e1dccc 00000000 nt!CmLoadKey+0xae
b9e1dd40 8061c57a 0007f5ec 0007f5d4 00000000 nt!NtLoadKey2+0x1fc
b9e1dd54 8053d668 0007f5ec 0007f5d4 0007f618 nt!NtLoadKey+0x12
b9e1dd54 7c90e514 0007f5ec 0007f5d4 0007f618 nt!KiFastCallEntry+0xf8
WARNING: Frame IP not in any known module. Following frames may be wrong.
0007f618 00000000 00000000 00000000 00000000 0x7c90e514

STACK_COMMAND: kb
FOLLOWUP_IP:
nt!CmpFree+17
80632cd7 5d pop ebp
SYMBOL_STACK_INDEX: 3
SYMBOL_NAME: nt!CmpFree+17
FOLLOWUP_NAME: MachineOwner
MODULE_NAME: nt
IMAGE_NAME: ntkrnlpa.exe
DEBUG_FLR_IMAGE_TIMESTAMP: 4bd6e0e9
FAILURE_BUCKET_ID: 0xc2_43_nt!CmpFree+17
BUCKET_ID: 0xc2_43_nt!CmpFree+17
Followup: MachineOwner
---------
No other hardware is plugged in to the laptop. I checked the version of ntkrnlpa.exe and logonui.exe and they are an older version than on the XP sp3 machine that I have as a test system but I'm not sure if I should try replacing these files.

Any help greatly appreciated. I normally don't mind trying a reformat and reinstall but since I dont have any access to the machine in a running state (even in safe mode) I would like to avoid having to backup and reinstall everything.
 

rhys898

Thread Starter
Joined
Jan 4, 2011
Messages
3
Bump and update,

I tried known good ram to no avail. Still looping....

:( Help!!!!

Thanks.
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Staff online

Members online

Top