1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Windows XP displays primary hard drive as drive F: instead of Drive C:

Discussion in 'Windows XP' started by Smoother, Aug 17, 2004.

Thread Status:
Not open for further replies.
Advertisement
  1. Smoother

    Smoother Thread Starter

    Joined:
    Aug 4, 2004
    Messages:
    14
    Windows XP Pro displays the primary hard Drive set as the master on IDE 1 as drive F: instead of drive C:. I can not find the cause.....any ideas? Any help would be much appreciated. Thanks :)
     
  2. KHolloman

    KHolloman

    Joined:
    Jul 22, 2004
    Messages:
    896
    Have you tried to go into Disk Management and change it to C:?

    Also, has it always done this?
     
  3. crjdriver

    crjdriver Moderator

    Joined:
    Jan 2, 2001
    Messages:
    37,726
    I am guessing you have a card reader, usb type drive, zip drive, etc that was present during the install. This is a known "feature" of xp and win2k.

    While it is "Possible" to change a system drive letter, I do not recommend you do so. The reason is that when you install an app or game, it installs files to the winnt or winnt/system32 folder. The app will look for those files on F:\winnt or F:\winnt\system32; they are now on C. The app will not run or give an error message.

    Unless you really want your system drive to read C, I would leave it alone. If you really want it to read C, I would do a clean install. Disconnecting any other drives.

    Here are the instructions for changing a system drive letter in xp or win2k. As you can see it is a pretty involved process and you will need to reinstall apps anyway. That is why I recommend a clean install.


    Make a full system backup of the computer and system state.
    Log on as an Administrator.
    Start Regedt32.exe.
    Go to the following registry key:
    HKEY_LOCAL_MACHINE\SYSTEM\MountedDevices

    Click MountedDevices.
    On the Security menu, click Permissions.
    Verify that Administrators have full control. Change this back when you are finished with these steps.
    Quit Regedt32.exe, and then start Regedit.exe.
    Locate the following registry key:
    HKEY_LOCAL_MACHINE\SYSTEM\MountedDevices

    Find the drive letter you want to change to (new). Look for "\DosDevices\C:".
    Right-click \DosDevices\C:, and then click Rename.

    Note You must use Regedit instead of Regedt32 to rename this registry key.
    Rename it to an unused drive letter "\DosDevices\Z:".

    This frees up drive letter C.
    Find the drive letter you want changed. Look for "\DosDevices\D:".
    Right-click \DosDevices\D:, and then click Rename.
    Rename it to the appropriate (new) drive letter "\DosDevices\C:".
    Click the value for \DosDevices\Z:, click Rename, and then name it back to "\DosDevices\D:".
    Quit Regedit, and then start Regedt32.
    Change the permissions back to the previous setting for Administrators (this should probably be Read Only).
    Restart the computer.
     
  4. Smoother

    Smoother Thread Starter

    Joined:
    Aug 4, 2004
    Messages:
    14
    Thanks.....I tried to change the drive to C: but it wouldn't work......everything seems to work just fine....so I am going to leave it alone until I have to do a clean install in the future. I suspect the USB drive and zip drive that were connected at the time of the install are the culprits. Again many thanks
     
  5. crjdriver

    crjdriver Moderator

    Joined:
    Jan 2, 2001
    Messages:
    37,726
    You are welcome. Unless you go through the entire procedure that I posted, you cannot change a system drive letter. Even if you do change it, you may have problems.

    BTW good decision to leave it alone. For the next install, just disconnect the other drives. Add them in after you install.
     
  6. norton850

    norton850

    Joined:
    Mar 8, 2004
    Messages:
    7,794
    crjdriver

    Thanks for this info. I've always wondered why I had a "F" boot drive
     
  7. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/263163

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice