1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

windows xp service pack 1

Discussion in 'Windows XP' started by chaltun, Feb 14, 2003.

Thread Status:
Not open for further replies.
Advertisement
  1. chaltun

    chaltun Thread Starter

    Joined:
    Apr 29, 2001
    Messages:
    78
    Dear Sirs:
    I just downloaded windows xp sp1. After installed i just checked the error log and found.....

    "windows xp hotfix migration failed, leaving windows xp partially
    updated. See C;\Windows\xpsp1hfm.log for more details" I went to the log file and found the following

    "[2003/02/14 01:13:20 BEGIN]

    Executing "C:\WINDOWS\system32\xpsp1hfm.exe" with ommand line:
    C:\WINDOWS\system32\xpsp1hfm.exe -SP1Upgrade
    Process: xpsp1hfm.exe (2532)
    ParentProcess: update.exe (3940)
    Enter SP1AfterInstallMain
    FindFirstFile C:\WINDOWS\$xpsp1hfm$\*.*
    QFE Q811630 has no backup directory to migrate.
    Migrating QFE Q811630 with comamnd line: update.exe -Z -Q

    RegOpenKeyEx(Software\Microsoft\Windows\CurrentVersion\Uninstall\Q811630 )
    failed 2
    Migration failed.
    Migrating QFE Q810833 with comamnd line: update.exe -Z -Q
    Return code: 0
    Migrating QFE Q810577 with comamnd line: update.exe -Z -Q
    Return code: 3010
    Migrating QFE Q329834 with comamnd line: update.exe -Z -Q
    Return code: 0
    Migrating QFE Q329390 with comamnd line: update.exe -Z -Q
    Return code: 0
    Migrating QFE Q329048 with comamnd line: update.exe -Z -Q
    Return code: 0
    Migrating QFE Q328310 with comamnd line: update.exe -Z -Q
    Return code: 3010

    Migration of following hotfixes failed. To secure and ensure
    reliability of this computer, please reinstall these hotfixes by executing installation from respective location as listed below:
    Hotfix Number Command line to install the Hotfix
    -------------
    -----------------------------------------------------------
    -----------
    Q811630 C:\WINDOWS\$xpsp1hfm$\Q811630update\update.exe
    Exit SP1AfterInstallMain
    Return code to parent process: 1603


    [2003/02/14 01:18:46 END]

    Can anyone explain to me what should I do? I hope someone can! I'm a bit new to this.
    Thank you.
     
  2. mal1930

    mal1930

    Joined:
    Apr 27, 2002
    Messages:
    860
    HI, I am not an expert but the Number is for the data base at Microsoft. If you go there and enter the Qnumber in the search box it will take you to a page of explanation. (811630) without the Q.

    There are 2 numbers that should answer your queries but offhand it looks as if you will have to reinstall the update again. peace Mal
     
  3. crjdriver

    crjdriver Moderator

    Joined:
    Jan 2, 2001
    Messages:
    39,482
    Just wondering did you download the entire SP or did you do windows update? Update sometimes misses files that are needed. I have had problems using the update feature and henceforth have always downloaded the entire SP. Here is a link to the service pack click on the network installation for the entire sp.
    http://www.microsoft.com/WindowsXP/pro/downloads/servicepacks/sp1/default.asp
    Once you download it you can burn it to a cd and in the future you will not have to download again if you reinstall.
     
  4. Dr Dave

    Dr Dave

    Joined:
    Apr 8, 2002
    Messages:
    1,156
    SP1 has caused alot of trouble. I would suggest you use "System Restore" to get rid of SP1, that should solve the problem, I personally don't use "System Restore" I use "GoBack as all
    restore points,etc are done automatically.
     
  5. crjdriver

    crjdriver Moderator

    Joined:
    Jan 2, 2001
    Messages:
    39,482
    I have installed SP1 on many computers [in excess of twenty]. None of which has had any problem whatsoever. I do use the network sp and not windows update. In my opinion this is what causes peoples problems with sp. In both win2k and xp I have noticed the same problem.
     
  6. chaltun

    chaltun Thread Starter

    Joined:
    Apr 29, 2001
    Messages:
    78
    Hey!
    I want to thank you guys for your help! I will implement your recommendation to clear up this matter but I just need to understand one more thing. I like to learn why I am doing things, not just to do them. See if you can answer this for me and then I will put this matter to bed.

    By the way I downloaded most of the updates before downloading service pack 1

    When I go to the windows update area and view my installation history it shows that windows xp service pack one and also update Q811630 have successfully been installed....they also show up in my c:\windows directory. Yet my error log shows that it's been partially installed. Why should there be a difference in the reporting? I guess I', looking for an easy way out of this problem.

    Please advise. Many Thanks.
     
  7. mal1930

    mal1930

    Joined:
    Apr 27, 2002
    Messages:
    860
    Hi, I am not certain about this but I think it relies more on what it has downloaded to you. You downloaded SP! So as far as it is concerned you have installed it.

    I had no trouble with SP1 but I downloaded to a clean install. Peace Mal
     
  8. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/118880

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice