1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Wireless connection constantly drops - Toshiba Satellite M45-S359 notebook

Discussion in 'Networking' started by HT24, Dec 23, 2007.

Thread Status:
Not open for further replies.
Advertisement
  1. HT24

    HT24 Thread Starter

    Joined:
    Dec 23, 2007
    Messages:
    12
    Hi,
    I have a Toshiba M45-S359 notebook laptop. About every 20-30 seconds, the wireless connection drops off (and immediately automatically reconnects). This is not a router issue because I tried 2 different routers (Linksys and Netgear) and also the wireless connection is perfectly stable on the other laptop I have. There are no interference issues. My phone operates at a very different (5.8 GHz) frequency. Also, the issue exists even when I have the laptop sitting very close to the router. Any suggestions/advice? Thanks in advance.
    HT
     
  2. bmt626

    bmt626

    Joined:
    Dec 21, 2005
    Messages:
    16
    have you tried updating your wireless driver? i had a problem like this with my linksys desktop card when i was using WPA untill i updated my driver or changed my key to a WEP key. Also what is the other laptop you have if they are same you could see if they have the same driver installed and go from there
     
  3. HT24

    HT24 Thread Starter

    Joined:
    Dec 23, 2007
    Messages:
    12
    I downloaded the latest wireless driver from the internet and installed it. The other laptop has Vista but I will also check the wireless driver version and go from there. Thanks for your help.
    HT
     
  4. JohnWill

    JohnWill Retired Moderator

    Joined:
    Oct 19, 2002
    Messages:
    106,418
    Are you using Windows WZC to control the connection or a 3rd party wireless client?
     
  5. HT24

    HT24 Thread Starter

    Joined:
    Dec 23, 2007
    Messages:
    12
    I tried it both ways - Windows as well as Intel's program to control the connection. There was no difference. Thank you.
    HT
     
  6. TerryNet

    TerryNet Moderator

    Joined:
    Mar 23, 2005
    Messages:
    77,002
    First Name:
    Terry
    When you tried WZC and Intel's utility did you make sure that the other one was not running? This is important, as they will conflict with each other.
     
  7. HT24

    HT24 Thread Starter

    Joined:
    Dec 23, 2007
    Messages:
    12
    When I installed Intel's Proset/Wireless application, I think it uninstalled the Windows one. I don't see it any more. Now the only thing managing the wireless connection is the Intel one. Thx.
    HT
     
  8. TerryNet

    TerryNet Moderator

    Joined:
    Mar 23, 2005
    Messages:
    77,002
    First Name:
    Terry
    You said that you have the latest driver, but from where? If the adapter is integrated the driver usually has to be from your laptop manufacturer's web site, as the manufacturer (or the motherboard's manufacturer) has to modify the one they get from Intel.
     
  9. HT24

    HT24 Thread Starter

    Joined:
    Dec 23, 2007
    Messages:
    12
  10. TerryNet

    TerryNet Moderator

    Joined:
    Mar 23, 2005
    Messages:
    77,002
    First Name:
    Terry
    You have implied that you are using Windows XP but haven't told us the wireless adapter brand and model, so I can't confirm for sure that you have the correct driver; but I assume that you do.

    Correct driver + only one wireless utility running + no interference + near the router + other PC proves the router's signal is fine. Assuming that you have Service Pack 2 I tend to think that the wireless adapter (or its antenna) is loose or failing.
     
  11. HT24

    HT24 Thread Starter

    Joined:
    Dec 23, 2007
    Messages:
    12
    Thx. If you could tell me how to extract this information (wireless adapter brand and model), and also how to confirm if I have Service Pack 2, that would be great. I am not at all tech-savvy, hence these (silly) questions! Greatly appreciate your help.

    Here is what I am seeing:
    Under Network Adapters in Device Manager:
    - 1394 Net Adapter
    - Intel(R) PRO/Wireless 2200BG Network Connection
    - Marvell Yukon 88R8036 PCI-E Fast Ethernet Controller

    Under 1394 Net Adapter:
    Manufacturer is Microsoft, location is Texas Instruments OHCI compliant IEEE.
    Driver provider is Microsoft, date is 7/1/2001, version is 5.1.2525.9

    Under Intel(R) PRO/Wireless 2200BG Network Connection:
    1) General - no version listed; it just says location - PCI bus 5, device 4, function 0
    2) Driver - Provider is Intel, Date is 7/25/07, version is 9.0.4.37

    BTW - I tried to run/install the driver from this location (http://www.csd.toshiba.com/cgi-bin/...ijhhefcgfkceghdgngdgmm.0&ct=DL&all_docs=false)
    but I am not sure if it worked. Under the Network adapter properties (under device manager), under Driver, it says Driver version 9.0.4.37, dated 7/25/2007.
    I could not manually update the driver because it is looking for a *.inf file which cannot be located inside the zipped driver file. The way the zipped driver file works is that when I double-click to open it, it directly runs the setup - i.e., it does not show me the contents of the zipped file...
     
  12. TerryNet

    TerryNet Moderator

    Joined:
    Mar 23, 2005
    Messages:
    77,002
    First Name:
    Terry
    You have the Intel(R) PRO/Wireless 2200BG wireless adapter; you "extracted" that information from Device Manager. :) So, you are not finding the right driver from Toshiba. Don't know if this is the latest, but at least it's for your adapter: http://www.csd.toshiba.com/cgi-bin/...ijhhefcgfkceghdgngdgmm.0&ct=DL&all_docs=false

    Right click on 'My Computer' - Properties - General tab - the Service Pack number is listed under the ''System:' heading.
     
  13. HT24

    HT24 Thread Starter

    Joined:
    Dec 23, 2007
    Messages:
    12
    Ok.. I will give this a shot. Thanks!
    HT
     
  14. HT24

    HT24 Thread Starter

    Joined:
    Dec 23, 2007
    Messages:
    12
    BTW, Service Pack is 2.
    HT
     
  15. HT24

    HT24 Thread Starter

    Joined:
    Dec 23, 2007
    Messages:
    12
    I could not install this adapter driver; because it appears (from the error message) that I already have a newer version..Thx.
    HT
     
  16. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/664318

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice