wireless keyboard and mouse not functioning

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

onlygreg

Thread Starter
Joined
Jun 18, 2005
Messages
94
I have a microsoft wireless keyboard and mouse set comfort edition. It used to work fine on my old computer and now i have just run a repair install of windows and it doesnt work. WHen i installed it last time i didnt need drivers or anything and there are none on the internet anyway. All i have is the Intellittype and intellipoint programs that came with the product. These are just about config and do not contain drivers or anything. I plug in another USB optical mouse and it worked fine. My keyboard and mouse are both plugged into PS/2 ports, the mouse by an adaptor. What do i need to do to make them work again?
 

onlygreg

Thread Starter
Joined
Jun 18, 2005
Messages
94
another thing to note is that i can use my keyboard to go into BIOS and setup before the computer actually starts. The problem seems to be in windows. I did have both the keyboard and mouse working earlier today and they randomly stopped although the mouse was really jerky at least it worked.
 
Joined
Aug 16, 2005
Messages
4,560
Have you tried new batteries? I know I had an issue with a users jerky mouse, and it was a simple disconnect, reset, connect USB connector again, and press the connect button on the mouse.
 

onlygreg

Thread Starter
Joined
Jun 18, 2005
Messages
94
yes i did try new batteries earlier when the thing actually was working. This made no differerence. There is an on screen display of how the batteries are and both read almost full. This is also an indication that the computer is sencing the hardware but it cannot use it. I went into conrol panel/keyboard and /mouse and in keyboard it says no hardware is installed and in mouse it just says the one that i have been using to find my way around while trying to fix the problem.
 

onlygreg

Thread Starter
Joined
Jun 18, 2005
Messages
94
yeah i just did and it worked perfectly in this another computer that i had never used it in before. I also checked in that computers hardware and the keyboard had installed itself straight away. This dosnt happen on my other computer.
 
Joined
Aug 16, 2005
Messages
4,560
Maybe remove the hardware from the device manager. Right click on my computer>properties>hardware>device manager. Remove the wireless devices from the keyboard and mouse.

Use the wired keyboard and mouse, restart, and after the reboot try the wireless devices again.
 

onlygreg

Thread Starter
Joined
Jun 18, 2005
Messages
94
thats the thing, in the computer they wont work in they dont appear in the device manager.
 

onlygreg

Thread Starter
Joined
Jun 18, 2005
Messages
94
last night i plugged another keyboard in before i turned on the computer. This one worked fine but then i switched to the wireless keyboard and it worked as well, it had also been added to the hardware section of keyboards in control panel. This morning i turned it on again with the wireless keyboard plugged in and it didnt work anymore. THis is very strange can anyone help?
still nothing with the mouse.
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Members online

Top