Wireless keyboard stopped working

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Elviza

Thread Starter
Joined
Nov 20, 2005
Messages
147
Hello-- the other day my mouse and keyboard were working fine. I unplugged them to use on another computer and at first the arrow kept staying fixed (mouse was not working) and if I got the mouse working the keyboard didn't- finally I switched to my old wired components and did what I needed to do. Well, when I set my normal computer back up the mouse worked fine but i have been unable to get the wireless keyboard working again no matter what. i have reset it multiple times, changed the batteries, restarted the computer, unplugged it from computer and replugged it, etc. Keep getting the mouse working but no response from the keyboard (other than when I hit the 'connect' button on the main base and the keyboard the green light on keyboard does flash). I can't find the manual so I don't know if there is some weird key combination that maybe unlocks the keyboard??

Right now I am successfully using the wireless mouse but had to plug in my junky wired keyboard to type this message-- any advice would be appreciated. BTW it is a Logitech mx3000 and has worked perfectly since I bought it months ago except whenever it needed batteries.
 
Joined
Oct 1, 2005
Messages
80
Reseat the USB connector. Some usb plugs are picky and will not "see" the connection unless it's in all the way. Also check your device manager to see if anything has a splat (yellow triangle with an exclamation mark). Fix that problem, too.
 

Elviza

Thread Starter
Joined
Nov 20, 2005
Messages
147
Thanx-- I have already plugged and unplugged the connections a few times-- and when i did have the keyboard connected I checked the device manager and it claimed the keyboard was working properly...it's really strange.
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Members online

Top