Wireless mouse and keyboard lag

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

YerOldPoison

Thread Starter
Joined
Jul 2, 2010
Messages
51
Hey guys. Yet another thread by me!

I've got a wireless desktop set (Logitech MK250). The keyboard and the mouse work just fine, until I go play a game. Every few minutes my connection between the USB and the mouse or keyboard or sometimes both at the same time gets cut off/lagged. What the strange thing is that after cca. 3 seconds, when it's back to normal it does all the actions/responds to my typing that I've done in that mid-connection drop. I'm wondering if this is either a connection issue or a software issue. This only happnes when I play online games and at higher settings (tried low too, but it's still the same). Any suggestions on what this might all be about? And what can I do about it if at all!? I am really not willing to plug my old wired set back in and I really like to relax from time to time to play a game or two.


Regards,
YerOldPoison


PS: I am playing about a meter away from the USB receiver. Tho it still usually responds even at 5+ meters away from the receiver.
 
Joined
Feb 1, 2011
Messages
1
I am expereincing the same issues using the Logitec MK 250 keyboard (i have the mouse too but have not expereinced any lag with it ) the keyboard however will lag intermitently, for what feals like 30 seconds at a time or more. Then run a number of the comands i gave it once it comes back to life.

This only happens when i'm playing call of duty (the only game i have instaled thusfar) The issue only ocures to the keyboard (ie no game lag as i am typicly getting shot up or exploded as my keyboard is failing me :mad:) It also does not appear to have anything to do with the intesity of the graphic rendering at that moment or anything ells that is going on in the game.

this is a brand new comp with nearly nothing instaled on it other than the games and antivirus:

Win 7 64bit
Intel i7 870 @2.93ghz
gigabite motherboard
4gb 1600mhz Ram
ATI Radion 5700 w/ 1gb

If anyone can help us locate this issue i would like to know if this keyboard is a peace of junk or if there is somthing ells going on here.

P.s. I am also sitting less than 1m away from the comp and have moved the keyboard receiver to a direct lign of sight... the issue presists.
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Staff online

Top