Wireless mouse and keyboard

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

chris915

Thread Starter
Joined
Dec 12, 2004
Messages
163
Hi, i recently bought a wireless keyboard and mouse for my computer. Problem is that when i start up my computer if i leave the receiver plugged into computer via usb port it makes a strange buzzing kinda noise and wont load any further until i remove the receiver. It doesnt do this if i just restart the computer, only if it has been shut down and then started up. I have no idea whats causing this.

Anyone able to help?

Thanks in advance

Chris
 

Triple6

Rob
Retired Moderator
Joined
Dec 26, 2002
Messages
52,933
Probably a faulty USB port or controller. Does this happen with every USB port on the computer?
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Members online

Top