Wireless mouse not working post update Windows 10

LaurenceM

Thread Starter
Joined
Oct 16, 2020
Messages
7
Hi,

I was using mg laptop prior to update and working fine, mouse and all...post update in AM turnes laptop on suddenly wireless mouse not working...changed batteries made me buy new wireless mouse thinking my old mouse died on me however new mouse not even recognised when plugged in. Sorry if I aound weird using my phone atm.
 

LaurenceM

Thread Starter
Joined
Oct 16, 2020
Messages
7
I hope someone can help with this...I also tried to recover however unable to rollback to night before
 

Goddess-Bastet

Virginia
Joined
Apr 26, 2019
Messages
463
What’s the make & model of the wireless mouse?
Have you tried updating its drivers?
Have you tried uninstalling the mouse & reinstalling it?

How did you try rolling back? Was there any error message when you tried rolling back?
 

LaurenceM

Thread Starter
Joined
Oct 16, 2020
Messages
7
What’s the make & model of the wireless mouse?
Have you tried updating its drivers?
Have you tried uninstalling the mouse & reinstalling it?

How did you try rolling back? Was there any error message when you tried rolling back?
The drivers/mouse dont show up in the device manager so there is nothing to update/uninstall 😰
 

Goddess-Bastet

Virginia
Joined
Apr 26, 2019
Messages
463
Not even under View>show hidden devices?
If so then the mouse may not installed.
What’s the make & model of Mouse?
Is it connected via a USB dongle or directly via Windows inbuilt Bluetooth?
 

LaurenceM

Thread Starter
Joined
Oct 16, 2020
Messages
7
Not even under View>show hidden devices?
If so then the mouse may not installed.
What’s the make & model of Mouse?
Is it connected via a USB dongle or directly via Windows inbuilt Bluetooth?
No 😥 not even in hudden devices...it looks like it's not installed however it should be plug and play...
My old mouse is a jelly comb and the newly bought one is a g305 both connected via USB dongle
Im worried coz it seems my USB port doesnt recognise items being plugged in and I dont know how to fix this 😭
 

Goddess-Bastet

Virginia
Joined
Apr 26, 2019
Messages
463
Have you run the firmware update tool? Did it download any updates?

You would need to check to see if the mouse is set up correctly within the Light speed software.
If not the go through the setup again.
 

LaurenceM

Thread Starter
Joined
Oct 16, 2020
Messages
7
Have you run the firmware update tool? Did it download any updates?

You would need to check to see if the mouse is set up correctly within the Light speed software.
If not the go through the setup again.
It's all good guys...I surrendered and booked for a technician...it's fixed. Thanks for the help. Long live...🖖😅
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Members online

Top