Wireless mouse not working right

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

StanC

Thread Starter
Joined
Dec 4, 2001
Messages
325
Hi Guys
I use a wireless mouse with my desktop - it has been running without a problem for more than a year. Recently it started moving the cell pointer in a "shocky" manner. I replaced the batteries - but still not working right. It is a 2.4G made in China. Any thoughts?
StanC
 
Joined
Jun 14, 2020
Messages
107
1. Reset the mouse settings.

2. Use a system restore point before the issue

3. Check whether CPU or RAM is reaching 100 % while this glitch happens.

4. Create another user account. See whether the issue persists

It would be nice to know your OS version
 

StanC

Thread Starter
Joined
Dec 4, 2001
Messages
325
JKLE
My desktop:
OS Version: Microsoft Windows 10 Home, 64 bit, Build 18362, Installed 20190819093321.000000-240
Processor: Intel(R) Core(TM) i3-6100 CPU @ 3.70GHz, Intel64 Family 6 Model 94 Stepping 3, CPU Count: 4
Total Physical RAM: 4 GB
Unfortunately, I am not digitally savvy enough to understand how to do the steps you suggest.
StanC
 

flavallee

Frank
Trusted Advisor
Joined
May 12, 2002
Messages
82,060
We're not there, so it could be a very simple fix or it could be something more complicated.

Ignore steps #2 and #4 because that may cause you even more problems.

Switch to a USB wired mouse and see if your computer has the same issue.

Examine the bottom of the wireless mouse and make sure it's not dirty or clogged.

------------------------------------------------
 

StanC

Thread Starter
Joined
Dec 4, 2001
Messages
325
Well - another miracle. I decided to try a fix on my own. I shut down the computer. Pulled the little mouse transmitter that was plugged into a USB port. Rebooted. Plugged in the transmitter to a different port - and AMAZING - it now works without the bugginess. IT has only been a few minutes - so it may be wishful thinking. But I've got my fingers crossed.
If this turns out to be a permanent fix I'll mark the query SOLVED later today.
Thanks
StanC
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Staff online

Members online

Top