XP and Ultra ATA/100

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

sojum

Thread Starter
Joined
Jul 16, 2001
Messages
21
I have a WDC 40GB 7200 RPM ATA/100 drive than is performing considerably slower than it should under XP (according to SiSoft's Sandra benchmark utility). I installed the latest Intel ATA drivers for my motherboard's chipset (Tyan Tomcat i815T S2080, Intel 82801BA Controller) but see only a marginal improvement. To be certain the DMA33 drive (slave) I have using the same IDE channel isn't slowing it down, I removed it from the system and ran Sandra again to benchmark and got the exact same results.

I've noticed that if I display the IDE Primary controller in Device Manager, it shows that the drive is using DMA Mode 1. I have read elsewhere that ATA/100 is Mode 5, and if I run Intel's Application Accelerator tool it does show the drive as Mode 5. Has anyone had similar problems or can anyone offer any advice on how I can increase my drive speed?

In addition to the hardware above, I'm running a P3 750 100FSB with 256MB PC-133 RAM and 128MB PC-100 RAM. I have a CD-RW and CD-ROM on my second IDE channel, and I am using the correct 40 pin cable for the HD's.
 

sojum

Thread Starter
Joined
Jul 16, 2001
Messages
21
Thanks for the reply. Per my message above though, the problem is that these settings show my drive is using DMA Mode 1, when it should be showing DMA Mode 5 (and Intel's Application Accelerator utility does show it using DMA Mode 5).
 
Joined
Dec 20, 2001
Messages
11
Are you using a right IDE flatcable. You can regconize this flatcables by the smaller ripples ( smaller wires ) ??
 

sojum

Thread Starter
Joined
Jul 16, 2001
Messages
21
The Data Lifegaurd tools do show the drive as set to 100, and the Intel Application Acceleration tool also recognizes it as such. I do have the correct cable (as per the initial message, I am using the correct 40 pin cable for the HD's), but have not tried swapping it out with another DMA cable - I suppose that's worth a try at least.
 
Joined
Feb 5, 2001
Messages
97
I had this problem and found 2 things you can try , the first one is the one that worked for me....

1)-----------------------
1. Go to Device Manager
2. Go to "IDE ATA/ATAPI Controllers"
3. Remove "Primary IDE Channel"
4. Reboot
5. WinXP detect "Primary IDE Channel" again and ask you to reboot.

On reboot, your IDE drives should be detected correctly.If XP sets the

drive to "PIO Only" just reset it to "DMA if Available" and reboot

again...


2)--------------------------
Go into the registry to the the following Key and add a DWORD Value "EnableUDMA100"...and set it to 1....
[HKEY_LOCAL_MACHINE\SYSTEM\ControlSet\Control\Clas
s\{4D36E96A-E325-11CE-BFC1-08002BE10318}\0000]
EnableUDMA100=dword:00000001
 

sojum

Thread Starter
Joined
Jul 16, 2001
Messages
21
Thanks Drew. I'll give both of these a try.

Per previous threads: I swapped out the cable with no change (and double-checked my MB BIOS - which still shows the drive is using DMA Mode 5 even though WinXP doesn't).
 
Joined
Feb 5, 2001
Messages
97
I hope one of them helps you....I had the same thing with my Bios showing DMA 5 and XP was showing DMA 2....After I did step 1 all was well , this also works with CD Roms that use DMA but are stuck in PIO from XP.....Good Luck..
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Members online

Top