1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

XP HOME DEFAULT NW PROTOCOL (any way to change it?)

Discussion in 'Networking' started by ryandale, Feb 4, 2005.

Thread Status:
Not open for further replies.
Advertisement
  1. ryandale

    ryandale Thread Starter

    Joined:
    Dec 29, 2004
    Messages:
    16
    I use Windows XP Home on one of my computers, I use an old dos-based program which requires that the default protocol is IPX/SPX to connect to another server. When I originally upgraded from Windows 98, this system kept working and IPX/SPX stayed the default. Then I had to reinstall and I find out Windows XP Home has TCP/IP as the permanent default protocol. Now I can't get IPX/SPX as the default again.

    But there must be some regedit I could do rather than reinstalling 98 and then XP or buying an upgrade to Windows XP Pro...right?

    Please let me know if you have any ideas!
     
  2. StumpedTechy

    StumpedTechy

    Joined:
    Jul 7, 2004
    Messages:
    7,234
    Straight from windows XP help - this is how you make IPX/SPX the first item bound to the adapter so it will try it first.

    To modify the protocol bindings order
    You must be logged on as an administrator or a member of the Administrators group in order to complete this procedure. If your computer is connected to a network, network policy settings might also prevent you from completing this procedure.

    Open Network Connections.
    On the Advanced menu, click Advanced Settings
    On the Adapters and Bindings tab, under Connections, click the connection you want to modify.
    Under Bindings for Local Area Connection, click the protocol that you want to move up or down in the list, and then click the up or down arrow button.
     
  3. ryandale

    ryandale Thread Starter

    Joined:
    Dec 29, 2004
    Messages:
    16
    Well, this doesn't do quite what I needed.

    In Win98, you can do a little checkbox in NW settings to make IPX/SPX the default protocol.

    In W2K, to get the same result, I had to uninstall TCP/IP, reboot, install IPX/SPX, reboot and then install TCP/IP anew.

    In XP Pro, you can uncheck (but it won't let you uninstall) TCP/IP and then reboot, install IPX/SPX, reboot and then recheck TCP/IP anew.

    In XP Home, there is no choice on being able to temporarily turn off TCP/IP so that you can get IPX/SPX to be the default protocol.

    ...

    A friend was describing to me that there was a patch you can download to handle all the problems of Microsft XP ... I asked where I could get it and he said it was available from several different companies - Red Hat, Solaris...
     
  4. StumpedTechy

    StumpedTechy

    Joined:
    Jul 7, 2004
    Messages:
    7,234
    Your making no sense (at least to me) - if your IPX is bound first it will be the default protocol used. If you just don't want TCP/IP bound you can uncheck it from the binding list.

    Also see this -

    Set up Bindings: By default, Windows XP binds all installed protocols to each network connection and service. We need to remove various bindings to limit the services using each protocol. The mechanism is very different to Win9X and in XP one should:
    Open the Network Connections folder and on the Advanced drop down menu click Advanced Settings
    Click the connection name under Connections. The appropriate bindings appear under Bindings.
    To remove a binding, un-check the corresponding box. For example, we want to use IPX/SPX instead of TCP/IP for file sharing,so we un-bind TCP/IP from both File and Printer Sharing and Client for Microsoft Networks.
    It is also necessary to right click the LAN Network Connection and click properties then untick the TCP/IP box to completely prevent TCP/IP being used instead of IPX/SPX.
    Restart your computer even if not requested

    Again I am not sure what your saying is not working maybe someone else can jump in and add more to what I have put in and maybe clarify it.
     
  5. ryandale

    ryandale Thread Starter

    Joined:
    Dec 29, 2004
    Messages:
    16
    Stumped -

    I didn't fully read your first posting, so I thought I had tried it. Thanks for being persistent - I printed off the instructions this time and went and tried them and of course it worked great, it will save my friend and I a lot of time in installing some systems.

    Thanks again=
    Ryan
     
  6. Squashman

    Squashman Trusted Advisor

    Joined:
    Apr 4, 2003
    Messages:
    19,786
    Good Job StumpedTechy!
     
  7. StumpedTechy

    StumpedTechy

    Joined:
    Jul 7, 2004
    Messages:
    7,234
    No problem. I was hoping I hadn't misread something and you were asking for something 100% different than what I was suggesting! Glad to see its working for you.
     
  8. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/326879

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice